www-client/surfraw: Switch to HTTPS
authorJeroen Roovers <jer@gentoo.org>
Sun, 14 Jul 2019 18:27:16 +0000 (20:27 +0200)
committerJeroen Roovers <jer@gentoo.org>
Sun, 14 Jul 2019 18:30:06 +0000 (20:30 +0200)
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
www-client/surfraw/Manifest
www-client/surfraw/surfraw-2.3.0-r1.ebuild [new file with mode: 0644]
www-client/surfraw/surfraw-99999.ebuild

index ee68fecec4b9a333cdf6b3e0dc6fa547e6d04f64..0007f9e35cd378fb9d14ba2ac32df7468e36e1bf 100644 (file)
@@ -1,2 +1,3 @@
+DIST Surfraw-surfraw-2.3.0.tar.bz2 114065 BLAKE2B 91105b225737fe8f3a016e8c723421a2386c48f0c245b6ed119e4cc0f1032c9362e83a062134d0fef8b1cb14f58af07d3d9abe72c4efef9e79c6eb4c93bab25c SHA512 43f0dd2b48a045a47e73e8ef8058e0590a0409367e8378a086497ef912c58317614ba318b006913803529a51a641858a58c1f9f6a2f93dcdea9a45a26484af02
 DIST surfraw-2.2.9.tar.gz 200042 BLAKE2B c360da9826b6473a1159e67a19e9e12eaf4697b5be4373088169eb6ee1b85f126854f8594c5de8fd0517b7020947be42a5678d1ed7bd798f0925c53a68728c15 SHA512 81ddfc5300f5f052e09187144f39c0e1f0d6a0df9ad82d4457b60498278061ac6736a8236bd2b3516f6ad885d22c8616372b354f11b2dbb46ef4f3790456f016
 DIST surfraw-2.3.0.tar.gz 205557 BLAKE2B 35ca2b46f14fc123fd014682a413c6f22e8c9f05d85e8e76660e099536fda8648446757d467afbe8807c91ec1628c568854ebfda48953e9499a018c30f2bc5ee SHA512 51cdfb68bab701bce635a64ab3d5af669b2330c895180d01cca1c6f3c4005972ba4c573b693df59a2cc4fdb97d4fd11224bae500bbd4a17c3ab446de5241c9a0
diff --git a/www-client/surfraw/surfraw-2.3.0-r1.ebuild b/www-client/surfraw/surfraw-2.3.0-r1.ebuild
new file mode 100644 (file)
index 0000000..2ab0824
--- /dev/null
@@ -0,0 +1,94 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools bash-completion-r1
+
+DESCRIPTION="A fast unix command line interface to WWW"
+HOMEPAGE="https://gitlab.com/surfraw/Surfraw"
+SRC_URI="${HOMEPAGE}/-/archive/${P}/${PN^}-${P}.tar.bz2"
+SLOT="0"
+LICENSE="public-domain"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
+
+RDEPEND="
+       dev-lang/perl
+"
+RESTRICT="test"
+DOCS=(
+       AUTHORS ChangeLog HACKING NEWS README TODO
+)
+PATCHES=(
+       "${FILESDIR}"/${PN}-2.3.0-completion.patch
+)
+S=${WORKDIR}/${PN^}-${P}
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+src_configure() {
+       econf --with-elvidir='$(datadir)'/surfraw
+}
+
+src_install() {
+       default
+
+       newbashcomp surfraw-bash-completion ${PN}
+       bashcomp_alias ${PN} sr
+
+       docinto examples
+       dodoc examples/README
+       insinto /usr/share/doc/${PF}/examples
+       doins examples/uzbl_load_url_from_surfraw
+}
+
+pkg_preinst() {
+       has_version "=${CATEGORY}/${PN}-1.0.7"
+       upgrade_from_1_0_7=$?
+}
+
+pkg_postinst() {
+       local moves f
+
+       einfo
+       einfo "You can get a list of installed elvi by just typing 'surfraw' or"
+       einfo "the abbreviated 'sr'."
+       einfo
+       einfo "You can try some searches, for example:"
+       einfo "$ sr ask why is jeeves gay? "
+       einfo "$ sr google -results=100 RMS, GNU, which is sinner, which is sin?"
+       einfo "$ sr rhyme -method=perfect Julian"
+       einfo
+       einfo "The system configuration file is /etc/surfraw.conf"
+       einfo
+       einfo "Users can specify preferences in '~/.surfraw.conf'  e.g."
+       einfo "SURFRAW_graphical_browser=mozilla"
+       einfo "SURFRAW_text_browser=w3m"
+       einfo "SURFRAW_graphical=no"
+       einfo
+       einfo "surfraw works with any graphical and/or text WWW browser"
+       einfo
+       if [[ $upgrade_from_1_0_7 = 0 ]] ; then
+               ewarn "surfraw usage has changed slightly since version 1.0.7, elvi are now called"
+               ewarn "using the 'sr' wrapper script as described above.  If you wish to return to"
+               ewarn "the old behaviour you can add /usr/share/surfraw to your \$PATH"
+       fi
+       # This file was always autogenerated, and is no longer needed.
+       if [ -f "${EROOT}"/etc/surfraw_elvi.list ]; then
+               rm -f "${EROOT}"/etc/surfraw_elvi.list
+       fi
+
+       # Config file location changes in v2.2.6
+       for f in /etc/surfraw.{bookmarks,conf}; do
+               if [ -f "${EROOT}"${f} ]; then
+                       ewarn "${f} has moved to /etc/xdg/config/surfraw/${f##*.} in v2.2.6."
+                       moves=1
+               fi
+       done
+       if [ "${moves}" == 1 ]; then
+               ewarn "You must manually move, and update, the config files listed"
+               ewarn "above for surfraw v2.2.6 and above to use them."
+       fi
+}
index bc760e5d6112153d288cc65b775dead145cb6679..cf8930db4683aeac04cdc17d5e5d4840f7888145 100644 (file)
@@ -7,7 +7,6 @@ inherit autotools bash-completion-r1 git-r3
 DESCRIPTION="A fast unix command line interface to WWW"
 LICENSE="public-domain"
 HOMEPAGE="
-       http://surfraw.alioth.debian.org/
        https://gitlab.com/surfraw/Surfraw
 "
 EGIT_REPO_URI="https://gitlab.com/surfraw/Surfraw.git"