dev-util/scons: 3.0.5-r1 fix passthrough of $PATH env
authorband-a-prend <torokhov-s-a@yandex.ru>
Fri, 7 Jun 2019 21:32:36 +0000 (00:32 +0300)
committerMichał Górny <mgorny@gentoo.org>
Sat, 15 Jun 2019 14:19:17 +0000 (16:19 +0200)
The env-passthrough patch make possible to pass $PATH env
to scons build env while build of packages that use scons
as build system by call of escons() function from scons-util.eclass.
The escons() func. setup GENTOO_SCONS_ENV_PASSTHROUGH=1 variable
that make the patch mentioned above to be working.

The scons package doesn't call escons() so it get to setup
GENTOO_ENV_PASSTHROUTH=1 variable directly within python_test() phase.

This fix repairs Clang tests that failed because the clang and clang++
couldn't be found within scons test env.

Signed-off-by: Sergey Torokhov <torokhov_s_a@mail.ru>
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-util/scons/scons-3.0.5-r1.ebuild

index 5dba6c1f8dabdeabb91e76f972972501586666dc..e7f2ac66479c13e4f27b04b35b3d6c7c6ea66f64 100644 (file)
@@ -62,6 +62,8 @@ src_prepare() {
 }
 
 python_test() {
+       # set variable from escons() of scons-util.eclass to make env-passthrough patch work within test env
+       local -x GENTOO_SCONS_ENV_PASSTHROUGH=1
        cd "${WORKDIR}/${P}" || die
        "${EPYTHON}" runtest.py -a --passed \
                -j "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")" \