media-sound/sonata: 1.7_beta1_p20200212 version bump
authorAndreas Sturmlechner <asturm@gentoo.org>
Wed, 19 Feb 2020 20:38:54 +0000 (21:38 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Wed, 19 Feb 2020 20:40:08 +0000 (21:40 +0100)
Too many patches on top of 2016 release of 1.7_beta1.

Bug: https://bugs.gentoo.org/708170
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
media-sound/sonata/Manifest
media-sound/sonata/sonata-1.7_beta1_p20200212.ebuild [new file with mode: 0644]

index 10001967f46877d731bd53650ae88a4576e26a13..7b3aee904a770b061891d7260a1b4135e544bd53 100644 (file)
@@ -1 +1,2 @@
 DIST sonata-1.6.2.1.tar.bz2 314333 BLAKE2B a2d7f6f8b5fe4b774136c70e7a354a8b8d948f44e876e3d59b0a216cb482de6c9b5a38b1332347136466965bd0551a03ba53f9e554c969ce901e880fa691496e SHA512 8022b69380714e9c3c685c61d0f1e62be087fc2cbd77a55f32008edea53411f8493d416bd0a446ccb52b4b5603ba9f4a00b655af485d739932dc06af69345c27
+DIST sonata-1.7_beta1_p20200212.tar.gz 2259353 BLAKE2B 78befe6896d75033649e4f7333bc1487cc7462a66564860d93b4770cb7e86a6cc4656377b6e13defb07591b0a81cbd22653f01c5e9f20d75fcbf28a84551f7fb SHA512 bdff3ee3ec4d94a18604409efbca398f94633a510780f33d449921b69787521ad5d68285aa0fe7252191c1227435c42cf60bca0fe7764e1a8b3d887ff4be4ae6
diff --git a/media-sound/sonata/sonata-1.7_beta1_p20200212.ebuild b/media-sound/sonata/sonata-1.7_beta1_p20200212.ebuild
new file mode 100644 (file)
index 0000000..3f5b023
--- /dev/null
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+COMMIT=0c807e593f7571a654ad055cb126652d7f3a698d
+PYTHON_COMPAT=( python3_{6,7} )
+DISTUTILS_SINGLE_IMPL="true"
+DISTUTILS_USE_SETUPTOOLS="rdepend"
+inherit desktop distutils-r1
+
+DESCRIPTION="Elegant GTK+ music client for the Music Player Daemon (MPD)"
+HOMEPAGE="https://www.nongnu.org/sonata/"
+SRC_URI="https://github.com/multani/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="dbus taglib"
+
+BDEPEND="
+       virtual/pkgconfig
+"
+RDEPEND="
+       $(python_gen_cond_dep '
+               dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+               dev-python/python-mpd[${PYTHON_MULTI_USEDEP}]
+               dbus? ( dev-python/dbus-python[${PYTHON_MULTI_USEDEP}] )
+               taglib? ( dev-python/tagpy[${PYTHON_MULTI_USEDEP}] )
+       ')
+"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+src_install() {
+       distutils-r1_src_install
+       doicon -s 128 sonata/pixmaps/sonata.png
+       rm -r "${D}"/usr/share/sonata || die
+}