sys-fs/inotify-tools: removed unused command line argument
authorDenis Pronin <dannftk@yandex.ru>
Sun, 23 Feb 2020 17:48:46 +0000 (20:48 +0300)
committerLars Wendler <polynomial-c@gentoo.org>
Tue, 25 Feb 2020 08:58:43 +0000 (09:58 +0100)
as result we get successful compilation with clang

Signed-off-by: Denis Pronin <dannftk@yandex.ru>
Closes: https://github.com/gentoo/gentoo/pull/14755
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
sys-fs/inotify-tools/files/inotify-tools-3.20.1-rm-unused-cmd-arg.patch [new file with mode: 0644]
sys-fs/inotify-tools/inotify-tools-3.20.1.ebuild

diff --git a/sys-fs/inotify-tools/files/inotify-tools-3.20.1-rm-unused-cmd-arg.patch b/sys-fs/inotify-tools/files/inotify-tools-3.20.1-rm-unused-cmd-arg.patch
new file mode 100644 (file)
index 0000000..8c4f6f5
--- /dev/null
@@ -0,0 +1,11 @@
+--- inotify-tools-3.20.1/src/Makefile.am
++++ inotify-tools-3.20.1/src/Makefile.am
+@@ -2,7 +2,7 @@
+ inotifywait_SOURCES = inotifywait.c common.c common.h
+ inotifywatch_SOURCES = inotifywatch.c common.c common.h
+-AM_CFLAGS = -Wall -Werror -Wpointer-arith -std=c99 -I../libinotifytools/src -L../libinotifytools/src
++AM_CFLAGS = -Wall -Werror -Wpointer-arith -std=c99 -I../libinotifytools/src
+ AM_CPPFLAGS = -I$(top_srcdir)/libinotifytools/src
+ LDADD = ../libinotifytools/src/libinotifytools.la
index 596dc81c50b12d7047cee66b2fc7a95387974972..34e25a33f645019c8093cfcacf4eaacda86b9e38 100644 (file)
@@ -17,6 +17,8 @@ IUSE="doc"
 DEPEND="doc? ( app-doc/doxygen )"
 RDEPEND=""
 
+PATCHES=( "${FILESDIR}/${P}-rm-unused-cmd-arg.patch" )
+
 src_prepare() {
        default
        eautoreconf