app-pda/libusbmuxd: restore v1.0.9
authorThomas Deutschmann <whissi@gentoo.org>
Wed, 18 Sep 2019 21:22:28 +0000 (23:22 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Wed, 18 Sep 2019 21:28:37 +0000 (23:28 +0200)
Fixes commit 9998a93ab8c86a06e8e9898b569ff5cfd789c694 which
deleted last stable version.

Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
app-pda/libusbmuxd/Manifest
app-pda/libusbmuxd/libusbmuxd-1.0.9.ebuild [new file with mode: 0644]

index f64f038a9721d066fd17c772d22932454d16d359..5b46379db698d6b21a33ffa98957769c5064e0a4 100644 (file)
@@ -1 +1,2 @@
 DIST libusbmuxd-1.0.10.tar.bz2 292649 BLAKE2B 7ec9a576cb20f7e87cf1f31e57e66100c496e5809142d225df9b3cc295a71546bed2d90f41df3144f7316ce0aec5f08fad850c528e27f336bf96e9578bcffd04 SHA512 180cde2e9d0860d07d29813e68abf8ca807f75e98424b50acfc1ce941ba4260922959e1047a7d2bc754470c08ed55d0a15c9367487bd41c635a52b4fbf8ff535
+DIST libusbmuxd-1.0.9.tar.bz2 265940 BLAKE2B fbdb5ac441a3bcda41b752737f6a5fa9975948d67abf5b1edd9b3e3f749ea65486892af3c679cfcfa5f8d9052f8d35c6a5b0a3a95d07c65385ca28ff7a2b8633 SHA512 f50ee580ac9b4c5e55ab596aabb0bdc09f710cc58edba98699499998c44f2b2cf064792390f235b2221af494ce3233acda699652066b9297cc3cb4e9f8a1cfa4
diff --git a/app-pda/libusbmuxd/libusbmuxd-1.0.9.ebuild b/app-pda/libusbmuxd/libusbmuxd-1.0.9.ebuild
new file mode 100644 (file)
index 0000000..53333b3
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit autotools-utils
+
+DESCRIPTION="USB multiplex daemon for use with Apple iPhone/iPod Touch devices"
+HOMEPAGE="http://www.libimobiledevice.org/"
+SRC_URI="http://www.libimobiledevice.org/downloads/${P}.tar.bz2"
+
+# tools/iproxy.c is GPL-2+, everything else is LGPL-2.1+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0/2" # based on SONAME of libusbmuxd.so
+KEYWORDS="amd64 ~arm ~arm64 ppc ~ppc64 x86"
+IUSE="kernel_linux static-libs"
+
+RDEPEND=">=app-pda/libplist-1.11:=
+       virtual/libusb:1
+       !=app-pda/usbmuxd-1.0.9
+       !<app-pda/usbmuxd-1.0.8_p1"
+DEPEND="${RDEPEND}
+       virtual/os-headers
+       virtual/pkgconfig"
+
+DOCS=( AUTHORS README )
+
+src_configure() {
+       local myeconfargs=( $(use_enable static-libs static) )
+       use kernel_linux || myeconfargs+=( --without-inotify )
+
+       autotools-utils_src_configure
+}