sys-process/lsof: Removed old.
authorLars Wendler <polynomial-c@gentoo.org>
Wed, 8 May 2019 08:09:50 +0000 (10:09 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Wed, 8 May 2019 08:10:05 +0000 (10:10 +0200)
Package-Manager: Portage-2.3.66, Repoman-2.3.12
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
sys-process/lsof/Manifest
sys-process/lsof/lsof-4.89.ebuild [deleted file]
sys-process/lsof/lsof-4.90.ebuild [deleted file]

index f99d3554d1e5f1dfe96e1e67e1b9f71eebfc4b01..2ea65705ba488f621dd988cd77bf343f87e6e1ef 100644 (file)
@@ -1,4 +1,2 @@
 DIST lsof-4.93.2.tar.gz 1319222 BLAKE2B 3b1756e7b72a0b0a2a11bce82a9b386f6dc5727d7837a4d544e2e33a98be3bfb46af50f0d8cc7b4a4bc419148d13f86d0f34cf806d90ba5d31312f426f81b7e9 SHA512 3c4a4d503391b1a648a08a4947c2e72a9629b169eddf50738b16a16a82f2a26967e4db2902e4a9157de5a73ae638db48e392117ffbd591e9fafd6b1725cd01a0
-DIST lsof_4.89.tar.bz2 784560 BLAKE2B 375ad53fd5c26a79559295fc8bcb6c495c00bf546019001b498f064dbd111f3581d60a577c199ce2cbd49dac0c061cdaea99de56d6bf069dceb0dd8b2f836942 SHA512 cafb0209143c7863e5cebe7efc33a2520d36f9e26222350e4edfa18debbcfb5c81f42f71469e5913fb21f49a7562bbe761b72dfc8f297dadf75ac619cdcb318c
-DIST lsof_4.90.tar.bz2 791758 BLAKE2B 250025eb553ee4574cadadcc57fa52bd97d8ce4432e25e9e028d3eec4033be54d5cbab5f02e0a04365033b5d179ca50efa591efe4ac28077f63513edee131084 SHA512 8c1481ab72867488d800ad68c9de5c936f034f044c90eeed220fb5683f68ba8efa3dd0efe1e23b4d4968750255b475150ad08ae8627dd9aa0a5025498418351a
 DIST lsof_4.91.tar.bz2 791734 BLAKE2B cd6211caedea34fdbb89266fd78a70902117eda6d4d7fa69115426f4a6f5cb5296fa09bbd946648d8d93483881e4ea4e2190f090be155c1081850e8366cfd05a SHA512 49f811941dd6303f7cb0655fddb8b1177af5d1b18f2bd1edfab09d2c128aea73daecf09c7a5375979c66ba764c88a6e70c9086b55c3634e3be01ab1aa12e9f92
diff --git a/sys-process/lsof/lsof-4.89.ebuild b/sys-process/lsof/lsof-4.89.ebuild
deleted file mode 100644 (file)
index 38ea4bc..0000000
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils flag-o-matic toolchain-funcs
-
-MY_P=${P/-/_}
-DESCRIPTION="Lists open files for running Unix processes"
-HOMEPAGE="ftp://lsof.itap.purdue.edu/pub/tools/unix/lsof/"
-SRC_URI="ftp://lsof.itap.purdue.edu/pub/tools/unix/lsof/${MY_P}.tar.bz2
-       ftp://lsof.itap.purdue.edu/pub/tools/unix/lsof/OLD/${MY_P}.tar.bz2
-       http://www.mirrorservice.org/sites/lsof.itap.purdue.edu/pub/tools/unix/lsof/${MY_P}.tar.bz2"
-
-LICENSE="lsof"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="examples ipv6 rpc selinux static"
-
-RDEPEND="rpc? ( net-libs/libtirpc )
-       selinux? ( sys-libs/libselinux )"
-DEPEND="${RDEPEND}
-       rpc? ( virtual/pkgconfig )"
-
-S=${WORKDIR}/${MY_P}/${MY_P}_src
-
-src_unpack() {
-       unpack ${A}
-       cd ${MY_P} || die
-       unpack ./${MY_P}_src.tar
-}
-
-src_prepare() {
-       epatch "${FILESDIR}"/${PN}-4.85-cross.patch #432120
-       # fix POSIX compliance with `echo`
-       sed -i \
-               -e 's:echo -n:printf:' \
-               AFSConfig Configure Customize Inventory tests/CkTestDB || die
-       # convert `test -r header.h` into a compile test
-       sed -i -r \
-               -e 's:test -r \$\{LSOF_INCLUDE\}/([[:alnum:]/._]*):echo "#include <\1>" | ${LSOF_CC} ${LSOF_CFGF} -E - >/dev/null 2>\&1:' \
-               -e 's:grep (.*) \$\{LSOF_INCLUDE\}/([[:alnum:]/._]*):echo "#include <\2>" | ${LSOF_CC} ${LSOF_CFGF} -E -P -dD - 2>/dev/null | grep \1:' \
-               Configure || die
-}
-
-target() {
-       case ${CHOST} in
-       *-darwin*)  echo darwin  ;;
-       *-freebsd*) echo freebsd ;;
-       *-solaris*) echo solaris ;;
-       *-aix*)     echo aixgcc  ;;
-       *)          echo linux   ;;
-       esac
-}
-
-src_configure() {
-       use static && append-ldflags -static
-
-       append-cppflags $(use rpc && $(tc-getPKG_CONFIG) libtirpc --cflags || echo "-DHASNOTRPC -DHASNORPC_H")
-       append-cppflags $(usex ipv6 -{D,U}HASIPv6)
-
-       export LSOF_CFGL="${CFLAGS} ${LDFLAGS} \
-               $(use rpc && $(tc-getPKG_CONFIG) libtirpc --libs)"
-
-       # Set LSOF_INCLUDE to a dummy location so the script doesn't poke
-       # around in it and mix /usr/include paths with cross-compile/etc.
-       touch .neverInv
-       LINUX_HASSELINUX=$(usex selinux y n) \
-       LSOF_INCLUDE=${T} \
-       LSOF_CC=$(tc-getCC) \
-       LSOF_AR="$(tc-getAR) rc" \
-       LSOF_RANLIB=$(tc-getRANLIB) \
-       LSOF_CFGF="${CFLAGS} ${CPPFLAGS}" \
-       ./Configure -n $(target) || die
-}
-
-src_compile() {
-       emake DEBUG="" all
-}
-
-src_install() {
-       dobin lsof
-
-       if use examples ; then
-               insinto /usr/share/lsof/scripts
-               doins scripts/*
-       fi
-
-       doman lsof.8
-       dodoc 00*
-}
-
-pkg_postinst() {
-       if [[ ${CHOST} == *-solaris* ]] ; then
-               einfo "Note: to use lsof on Solaris you need read permissions on"
-               einfo "/dev/kmem, i.e. you need to be root, or to be in the group sys"
-       elif [[ ${CHOST} == *-aix* ]] ; then
-               einfo "Note: to use lsof on AIX you need read permissions on /dev/mem and"
-               einfo "/dev/kmem, i.e. you need to be root, or to be in the group system"
-       fi
-}
diff --git a/sys-process/lsof/lsof-4.90.ebuild b/sys-process/lsof/lsof-4.90.ebuild
deleted file mode 100644 (file)
index 8a1faa6..0000000
+++ /dev/null
@@ -1,119 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit flag-o-matic toolchain-funcs
-
-MY_P="${P/-/_}"
-DESCRIPTION="Lists open files for running Unix processes"
-HOMEPAGE="ftp://lsof.itap.purdue.edu/pub/tools/unix/lsof/"
-SRC_URI="ftp://lsof.itap.purdue.edu/pub/tools/unix/lsof/${MY_P}.tar.bz2
-       ftp://lsof.itap.purdue.edu/pub/tools/unix/lsof/OLD/${MY_P}.tar.bz2
-       http://www.mirrorservice.org/sites/lsof.itap.purdue.edu/pub/tools/unix/lsof/${MY_P}.tar.bz2"
-
-LICENSE="lsof"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="examples ipv6 rpc selinux static"
-
-RDEPEND="rpc? ( net-libs/libtirpc )
-       selinux? ( sys-libs/libselinux )"
-DEPEND="${RDEPEND}
-       rpc? ( virtual/pkgconfig )"
-
-S="${WORKDIR}/${MY_P}/${MY_P}_src"
-
-PATCHES=(
-       "${FILESDIR}"/${PN}-4.85-cross.patch #432120
-       "${FILESDIR}"/${PN}-4.90-darwin-cppfix.patch #648084
-)
-
-src_unpack() {
-       unpack ${A}
-       cd ${MY_P} || die
-       unpack ./${MY_P}_src.tar
-}
-
-src_prepare() {
-       default
-       # fix POSIX compliance with `echo`
-       sed -i \
-               -e 's:echo -n:printf:' \
-               AFSConfig Configure Customize Inventory tests/CkTestDB || die
-       # Convert `test -r header.h` into a compile test.
-       # Make sure we convert `test ... -a ...` into two `test` commands
-       # so we can then convert both over into a compile test. #601432
-       sed -i -E \
-               -e '/if test .* -a /s: -a : \&\& test :g' \
-               -e '/test -r/s:test -r \$\{LSOF_INCLUDE\}/([[:alnum:]/._]*):echo "#include <\1>" | ${LSOF_CC} ${LSOF_CFGF} -E - >/dev/null 2>\&1:g' \
-               -e 's:grep (.*) \$\{LSOF_INCLUDE\}/([[:alnum:]/._]*):echo "#include <\2>" | ${LSOF_CC} ${LSOF_CFGF} -E -P -dD - 2>/dev/null | grep \1:' \
-               Configure || die
-}
-
-target() {
-       case ${CHOST} in
-       *-darwin*)  echo darwin  ;;
-       *-freebsd*) echo freebsd ;;
-       *-solaris*) echo solaris ;;
-       *-aix*)     echo aixgcc  ;;
-       *)          echo linux   ;;
-       esac
-}
-
-src_configure() {
-       use static && append-ldflags -static
-
-       append-cppflags $(use rpc && $(tc-getPKG_CONFIG) libtirpc --cflags || echo "-DHASNOTRPC -DHASNORPC_H")
-       append-cppflags $(usex ipv6 -{D,U}HASIPv6)
-       [[ ${CHOST} == *-solaris2.11 ]] && append-cppflags -DHAS_PAD_MUTEX
-       if [[ ${CHOST} == *-darwin* ]] ; then
-               # make sys/proc_info.h available in ${T} because of LSOF_INCLUDE
-               # dummy location -- Darwin needs this for a Configure check to
-               # succeed
-               if [[ -e /usr/include/sys/proc_info.h ]] ; then
-                       mkdir -p "${T}"/sys || die
-                       ( cd "${T}"/sys && ln -s /usr/include/sys/proc_info.h ) || die
-               fi
-       fi
-
-       export LSOF_CFGL="${CFLAGS} ${LDFLAGS} \
-               $(use rpc && $(tc-getPKG_CONFIG) libtirpc --libs)"
-
-       # Set LSOF_INCLUDE to a dummy location so the script doesn't poke
-       # around in it and mix /usr/include paths with cross-compile/etc.
-       touch .neverInv
-       LINUX_HASSELINUX=$(usex selinux y n) \
-       LSOF_INCLUDE=${T} \
-       LSOF_CC=$(tc-getCC) \
-       LSOF_AR="$(tc-getAR) rc" \
-       LSOF_RANLIB=$(tc-getRANLIB) \
-       LSOF_CFGF="${CFLAGS} ${CPPFLAGS}" \
-       ./Configure -n $(target) || die
-}
-
-src_compile() {
-       emake DEBUG="" all
-}
-
-src_install() {
-       dobin lsof
-
-       if use examples ; then
-               insinto /usr/share/lsof/scripts
-               doins scripts/*
-       fi
-
-       doman lsof.8
-       dodoc 00*
-}
-
-pkg_postinst() {
-       if [[ ${CHOST} == *-solaris* ]] ; then
-               einfo "Note: to use lsof on Solaris you need read permissions on"
-               einfo "/dev/kmem, i.e. you need to be root, or to be in the group sys"
-       elif [[ ${CHOST} == *-aix* ]] ; then
-               einfo "Note: to use lsof on AIX you need read permissions on /dev/mem and"
-               einfo "/dev/kmem, i.e. you need to be root, or to be in the group system"
-       fi
-}