sci-visualization/nonolith-connect: Fix gcc6 support (#594330 by Peter Levine)
authorPacho Ramos <pacho@gentoo.org>
Sun, 9 Apr 2017 10:22:12 +0000 (12:22 +0200)
committerPacho Ramos <pacho@gentoo.org>
Sun, 9 Apr 2017 11:04:22 +0000 (13:04 +0200)
Package-Manager: Portage-2.3.5, Repoman-2.3.2

sci-visualization/nonolith-connect/files/1.1-gcc6.patch [new file with mode: 0644]
sci-visualization/nonolith-connect/nonolith-connect-1.1.ebuild

diff --git a/sci-visualization/nonolith-connect/files/1.1-gcc6.patch b/sci-visualization/nonolith-connect/files/1.1-gcc6.patch
new file mode 100644 (file)
index 0000000..815c3ca
--- /dev/null
@@ -0,0 +1,14 @@
+--- nonolith-connect-1.1/websocketpp/src/websocket_server_session.cpp.old      2016-09-25 18:13:31.820474134 -0400
++++ nonolith-connect-1.1/websocketpp/src/websocket_server_session.cpp  2016-09-25 18:38:52.654567787 -0400
+@@ -41,8 +41,11 @@
+ #include <iostream>
+ #include <sstream>
+ #include <string>
++
++#if __cplusplus < 201103L
+ #include <ext/algorithm>
+ using __gnu_cxx::copy_n;
++#endif
+ using websocketpp::server_session;
index c33a929da9168b24702c61df0dee06668f9ffb75..955e544fbc6193701da21149d056da7cfa918fd6 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
+EAPI=6
 
-inherit eutils scons-utils toolchain-funcs user
+inherit scons-utils toolchain-funcs user
 
 DESCRIPTION="CEE (Control - Experiment - Explore) analog multitool"
 HOMEPAGE="http://www.nonolithlabs.com/cee/"
@@ -16,20 +16,20 @@ IUSE=""
 
 RDEPEND="
        dev-libs/boost
-       virtual/udev"
+       virtual/udev
+"
 DEPEND="${RDEPEND}"
 
-PATCHES=( "${FILESDIR}/${PV}-cflags-respect.patch" )
+PATCHES=(
+       "${FILESDIR}/${PV}-cflags-respect.patch"
+       "${FILESDIR}/${PV}-gcc6.patch"
+)
 
 pkg_setup() {
        tc-export CC CXX
        enewuser nonolithd -1 -1 /dev/null usb
 }
 
-src_prepare() {
-       epatch "${PATCHES[@]}"
-}
-
 src_configure() {
        myesconsargs=(
                boost_static=0