projects
/
gentoo.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
ee07a70
)
dev-python/urllib3: Enable testing on py3.8
author
Michał Górny
<mgorny@gentoo.org>
Sun, 22 Mar 2020 07:04:59 +0000
(08:04 +0100)
committer
Michał Górny
<mgorny@gentoo.org>
Sun, 22 Mar 2020 07:26:15 +0000
(08:26 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/urllib3/urllib3-1.25.8.ebuild
patch
|
blob
|
history
diff --git
a/dev-python/urllib3/urllib3-1.25.8.ebuild
b/dev-python/urllib3/urllib3-1.25.8.ebuild
index 4770e497d12f0b0030b8f7a029b13dd80a9dfdc3..ef0f1ab8a4a357a6cca7491e7f332a9b240df22b 100644
(file)
--- a/
dev-python/urllib3/urllib3-1.25.8.ebuild
+++ b/
dev-python/urllib3/urllib3-1.25.8.ebuild
@@
-40,7
+40,7
@@
BDEPEND="
>=dev-python/trustme-0.5.3[${PYTHON_USEDEP}]
$(python_gen_cond_dep '
>=www-servers/tornado-4.2.1[${PYTHON_USEDEP}]
- '
python{2_7,3_{5,6,7}}
)
+ '
'python*'
)
)
"
@@
-78,7
+78,7
@@
python_test() {
local -x CI=1
# FIXME: get tornado ported
case ${EPYTHON} in
- python
2*|python3.[567]
)
+ python
*
)
pytest -vv || die "Tests fail with ${EPYTHON}"
;;
esac