dev-ros/gazebo_plugins: Bump to 2.8.7.
authorAlexis Ballier <aballier@gentoo.org>
Mon, 18 May 2020 14:56:33 +0000 (16:56 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Mon, 18 May 2020 15:18:23 +0000 (17:18 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
dev-ros/gazebo_plugins/Manifest
dev-ros/gazebo_plugins/gazebo_plugins-2.8.7.ebuild [new file with mode: 0644]

index caa693e6afa87e374c3a1aded2847f0ee2f593a1..84927b5090b760b6467576be895f007fa383c42f 100644 (file)
@@ -1 +1,2 @@
 DIST gazebo_ros_pkgs-2.8.5.tar.gz 1854305 BLAKE2B f82021144b788b5fe19269ad28e1970a5f932ec91f7afdc0e45c4870125138b51cfadd794c08b52836f21e9d07c026cda80656794201b606b11b344ae73847e8 SHA512 124af0cff7933ce61127fd3ea61261e94b154954586af420c78775a6e4c69a741402aa563cb8d12a6b0f8a794a3948533c0a01555b00546c7c89742e43b25666
+DIST gazebo_ros_pkgs-2.8.7.tar.gz 1860830 BLAKE2B 2d0bf4774b1eff0bc658baf101d3450e5d94bcf8603a6e012b8a62422eb6a6b32e3c00c82f2854182ff990cf5017c23dac02d645c6a634d9fdb34403870ffd20 SHA512 3326c88dd7145a5beeaa0bd9c19f6abc2fb5483cfff1748b01c8f137c7223ffef80ff0df5cd0a2cb255006eaa44eef60cc878b362eed4a1d9a43a1a09ad24eaa
diff --git a/dev-ros/gazebo_plugins/gazebo_plugins-2.8.7.ebuild b/dev-ros/gazebo_plugins/gazebo_plugins-2.8.7.ebuild
new file mode 100644 (file)
index 0000000..88ed4a6
--- /dev/null
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-simulation/gazebo_ros_pkgs"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+CATKIN_HAS_MESSAGES=yes
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Robot-independent Gazebo plugins for sensors, motors and dynamic reconfigurable components"
+LICENSE="BSD Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-ros/gazebo_dev
+       dev-ros/gazebo_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/roscpp
+       dev-ros/rospy
+       dev-ros/nodelet
+       dev-ros/angles
+       dev-ros/std_srvs
+       dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+       dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/urdf
+       dev-ros/tf
+       dev-ros/tf2_ros
+       dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+       dev-ros/driver_base[${PYTHON_USEDEP}]
+       dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/trajectory_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/pcl_conversions
+       dev-ros/image_transport
+       dev-ros/rosconsole
+       dev-ros/cv_bridge
+       media-libs/opencv:=
+       dev-ros/polled_camera
+       dev-ros/diagnostic_updater
+       dev-ros/camera_info_manager
+       dev-ros/moveit_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-libs/libxml2
+       >=sci-electronics/gazebo-7:=
+       dev-libs/protobuf:=
+       dev-games/ogre
+       sci-libs/pcl
+       dev-libs/boost:=
+       dev-ros/roslib[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"