Revert "www-client/chromium: add memory check based on MAKEOPTS"
authorMike Gilbert <floppym@gentoo.org>
Mon, 18 Dec 2017 17:02:33 +0000 (12:02 -0500)
committerMike Gilbert <floppym@gentoo.org>
Mon, 18 Dec 2017 17:02:33 +0000 (12:02 -0500)
This reverts commit 7efa454f0f38f0ec0cc36404faf7a16600e8a0f4.

The job count may not have a direct relationship with memory usage in
certain circumstances. Users are expected to manage their MAKEOPTS with
respect to both CPU cores and available memory and other factors like
use for ccache and distcc.

Closes: https://bugs.gentoo.org/641564

www-client/chromium/chromium-63.0.3239.108.ebuild
www-client/chromium/chromium-64.0.3282.24.ebuild
www-client/chromium/chromium-65.0.3294.5.ebuild

index 992afee3e79264a104b958400408c2d4164fff2d..c5e75dfa71e9ce0abe4a2fb4a4e82e59b8fb65f1 100644 (file)
@@ -8,7 +8,7 @@ CHROMIUM_LANGS="am ar bg bn ca cs da de el en-GB es es-419 et fa fi fil fr gu he
        hi hr hu id it ja kn ko lt lv ml mr ms nb nl pl pt-BR pt-PT ro ru sk sl sr
        sv sw ta te th tr uk vi zh-CN zh-TW"
 
-inherit check-reqs chromium-2 eutils gnome2-utils flag-o-matic multilib multiprocessing ninja-utils pax-utils portability python-any-r1 readme.gentoo-r1 toolchain-funcs versionator xdg-utils
+inherit check-reqs chromium-2 eutils gnome2-utils flag-o-matic multilib ninja-utils pax-utils portability python-any-r1 readme.gentoo-r1 toolchain-funcs versionator xdg-utils
 
 DESCRIPTION="Open-source version of Google Chrome web browser"
 HOMEPAGE="http://chromium.org/"
@@ -164,24 +164,16 @@ pre_build_checks() {
        fi
 
        # Check build requirements, bug #541816 and bug #471810 .
-       local reqmem=3
+       CHECKREQS_MEMORY="3G"
        CHECKREQS_DISK_BUILD="5G"
        eshopts_push -s extglob
        if is-flagq '-g?(gdb)?([1-9])'; then
                CHECKREQS_DISK_BUILD="25G"
                if ! use component-build; then
-                       reqmem=16
+                       CHECKREQS_MEMORY="16G"
                fi
        fi
        eshopts_pop
-
-       local jobs=$(makeopts_jobs)
-       if (( jobs > reqmem )); then
-               CHECKREQS_MEMORY="${jobs}G"
-       else
-               CHECKREQS_MEMORY="${reqmem}G"
-       fi
-
        check-reqs_pkg_setup
 }
 
index c08e304f682e11e3f2bcbb887056742e1881feab..299b793208063cc49b25798268c1186ba68f3120 100644 (file)
@@ -8,7 +8,7 @@ CHROMIUM_LANGS="am ar bg bn ca cs da de el en-GB es es-419 et fa fi fil fr gu he
        hi hr hu id it ja kn ko lt lv ml mr ms nb nl pl pt-BR pt-PT ro ru sk sl sr
        sv sw ta te th tr uk vi zh-CN zh-TW"
 
-inherit check-reqs chromium-2 eutils gnome2-utils flag-o-matic multilib multiprocessing ninja-utils pax-utils portability python-any-r1 readme.gentoo-r1 toolchain-funcs versionator xdg-utils
+inherit check-reqs chromium-2 eutils gnome2-utils flag-o-matic multilib ninja-utils pax-utils portability python-any-r1 readme.gentoo-r1 toolchain-funcs versionator xdg-utils
 
 DESCRIPTION="Open-source version of Google Chrome web browser"
 HOMEPAGE="http://chromium.org/"
@@ -164,24 +164,16 @@ pre_build_checks() {
        fi
 
        # Check build requirements, bug #541816 and bug #471810 .
-       local reqmem=3
+       CHECKREQS_MEMORY="3G"
        CHECKREQS_DISK_BUILD="5G"
        eshopts_push -s extglob
        if is-flagq '-g?(gdb)?([1-9])'; then
                CHECKREQS_DISK_BUILD="25G"
                if ! use component-build; then
-                       reqmem=16
+                       CHECKREQS_MEMORY="16G"
                fi
        fi
        eshopts_pop
-
-       local jobs=$(makeopts_jobs)
-       if (( jobs > reqmem )); then
-               CHECKREQS_MEMORY="${jobs}G"
-       else
-               CHECKREQS_MEMORY="${reqmem}G"
-       fi
-
        check-reqs_pkg_setup
 }
 
index ec0f466ce837b7abc3850b87868d644e354be673..fe5b46bb9456fdad821e4046b3371d278defbed7 100644 (file)
@@ -8,7 +8,7 @@ CHROMIUM_LANGS="am ar bg bn ca cs da de el en-GB es es-419 et fa fi fil fr gu he
        hi hr hu id it ja kn ko lt lv ml mr ms nb nl pl pt-BR pt-PT ro ru sk sl sr
        sv sw ta te th tr uk vi zh-CN zh-TW"
 
-inherit check-reqs chromium-2 eutils gnome2-utils flag-o-matic multilib multiprocessing ninja-utils pax-utils portability python-any-r1 readme.gentoo-r1 toolchain-funcs versionator xdg-utils
+inherit check-reqs chromium-2 eutils gnome2-utils flag-o-matic multilib ninja-utils pax-utils portability python-any-r1 readme.gentoo-r1 toolchain-funcs versionator xdg-utils
 
 DESCRIPTION="Open-source version of Google Chrome web browser"
 HOMEPAGE="http://chromium.org/"
@@ -164,24 +164,16 @@ pre_build_checks() {
        fi
 
        # Check build requirements, bug #541816 and bug #471810 .
-       local reqmem=3
+       CHECKREQS_MEMORY="3G"
        CHECKREQS_DISK_BUILD="5G"
        eshopts_push -s extglob
        if is-flagq '-g?(gdb)?([1-9])'; then
                CHECKREQS_DISK_BUILD="25G"
                if ! use component-build; then
-                       reqmem=16
+                       CHECKREQS_MEMORY="16G"
                fi
        fi
        eshopts_pop
-
-       local jobs=$(makeopts_jobs)
-       if (( jobs > reqmem )); then
-               CHECKREQS_MEMORY="${jobs}G"
-       else
-               CHECKREQS_MEMORY="${reqmem}G"
-       fi
-
        check-reqs_pkg_setup
 }