sci-mathematics/maxima: fix amd64 build with USE=clozurecl.
authorMichael Orlitzky <mjo@gentoo.org>
Fri, 27 Mar 2020 03:33:22 +0000 (23:33 -0400)
committerMichael Orlitzky <mjo@gentoo.org>
Fri, 27 Mar 2020 03:42:07 +0000 (23:42 -0400)
The maxima build needs some special-case hacking on amd64 with
clozurecl. Thanks to slyfox for the patch.

Closes: https://bugs.gentoo.org/665364
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
sci-mathematics/maxima/maxima-5.43.2.ebuild

index 7c68f0a0e322b3f219ef15703275118a852ca3b9..88f7e81d580dc1e50bcc8606af2e60eaedb09f38 100644 (file)
@@ -129,9 +129,19 @@ src_configure() {
                if [ ${CONF} = . ]; then
                        CONF=${LISPS[${n}]}
                fi
+               if [[ ${CONF} == ccl ]]; then
+                       # 64-bit version of clozurecl is enabled
+                       # by --enable-ccl64, not by --enable-ccl.
+                       # bug #665364
+                       use amd64 && CONF=ccl64
+               fi
                CONFS="${CONFS} --enable-${CONF}"
        done
 
+       # Gentoo calls 'ccl' both 32-bit and 64-bit version of clozurecl.
+       # bug #665364
+       CONFS="${CONFS} --with-ccl64=ccl"
+
        # enable existing translated doc
        if use nls; then
                for lang in ${LANGS}; do