dev-libs/appstream-glib: version bump 0.6.3 → 0.6.5
authorGilles Dartiguelongue <eva@gentoo.org>
Sat, 12 Nov 2016 11:25:41 +0000 (12:25 +0100)
committerGilles Dartiguelongue <eva@gentoo.org>
Sat, 12 Nov 2016 12:23:10 +0000 (13:23 +0100)
Package-Manager: portage-2.3.2

dev-libs/appstream-glib/Manifest
dev-libs/appstream-glib/appstream-glib-0.6.5.ebuild [new file with mode: 0644]

index 5821bd77e1e840bba54ade8727eb6cd4e0ce91b7..974a65f3688f7770fd86ed60b1a39fa312127e80 100644 (file)
@@ -3,3 +3,4 @@ DIST appstream-glib-0.5.15.tar.xz 1884660 SHA256 cc21f213f4aa1693e68b9edf3b79933
 DIST appstream-glib-0.5.16.tar.xz 1885896 SHA256 788de3f6480789ad1adc144b0e16978af5863365b7a1650b4f14d29ad848ec62 SHA512 c047d2f6a3cb46ebbcd4dd6165bcbfbaba6d0b20b45d94b933b36cfd62f8821c0e062c4932d0d9d846cdb866bddd611a1055baf21d9438b1fa50b8480ecd7c17 WHIRLPOOL b09d0335a28b138dac58d70257773c2f653808c53c6ea2c923f94612a8a86147e793b36194716a3e58897bff5d9c9d1b677244044020236391d63e05e1be19e5
 DIST appstream-glib-0.5.9.tar.xz 1868132 SHA256 f0e4818553fe763894c660fec2c461b8815f83869acbf165daf32e2e41a5b166 SHA512 3c39233df97c464bfc993b54cee7eea01407220de39f833e34a017f6efc4c9bad0eb1762d72aed5eee94bb6a66044c7e031ede6685e1804b7ad6833b12fa9f7b WHIRLPOOL bbcc4318fafb1c3d94a8d695b924d2dec6f8c1bc968de3ca1480a8db6df47b7f30d2b656be09d7b6c2d7ed919b943452eca5b35e4559ff869872e97374228234
 DIST appstream-glib-0.6.3.tar.xz 1944512 SHA256 3ec355c950b86cd792b6e396a5a4a72487999e300fcacf7466a663974ec4ad24 SHA512 aae4885e32bc6f0247f6e8f415471531a8c28976e1ba4bd977200d72e24a04dfc2370395e3e0ea6e052386a963540cb91f025cd4f1ab837404762f1be2a76ff0 WHIRLPOOL 5bc9874e9f0708064f93fca8938d3708171dbf4cd356c8475e6d804ba109e51fc0b00d5dc4ac547f55c8a37c358c0d8fad6900ea214e8760b6da999be3f8c252
+DIST appstream-glib-0.6.5.tar.xz 1948908 SHA256 b6b77540b03ca56d7a8493d5f50ded747b6033e0437d8e4c516b5228e27b2a1a SHA512 606befae4fd675757e276a13679e1355359179537e701c8b14bb0b0ef0f21105231f2fa1338ac7776faa649a076da3e83f5dcb77120d14bb3a8945aa2d8e1376 WHIRLPOOL 7cce5c75c8659f64a35ed01118b00468d00563b94ed26f3d467c1d875a9c768ede85dc635c5a6eff1c8aa7612decc67ff362c8b8cc6cef73a8ebf1c54a311054
diff --git a/dev-libs/appstream-glib/appstream-glib-0.6.5.ebuild b/dev-libs/appstream-glib/appstream-glib-0.6.5.ebuild
new file mode 100644 (file)
index 0000000..d638ac2
--- /dev/null
@@ -0,0 +1,60 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit bash-completion-r1 gnome2
+
+DESCRIPTION="Provides GObjects and helper methods to read and write AppStream metadata"
+HOMEPAGE="https://people.freedesktop.org/~hughsient/appstream-glib/"
+SRC_URI="https://people.freedesktop.org/~hughsient/${PN}/releases/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/8" # soname version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+introspection nls stemmer"
+
+RDEPEND="
+       app-arch/gcab
+       app-arch/libarchive
+       dev-db/sqlite:3
+       >=dev-libs/glib-2.45.8:2
+       >=dev-libs/json-glib-1.1.1
+       dev-libs/libyaml
+       >=media-libs/fontconfig-2.11:1.0
+       >=media-libs/freetype-2.4:2
+       >=net-libs/libsoup-2.51.92:2.4
+       sys-apps/util-linux
+       >=x11-libs/gdk-pixbuf-2.31.5:2
+       x11-libs/gtk+:3
+       x11-libs/pango
+       introspection? ( >=dev-libs/gobject-introspection-0.9.8:= )
+       stemmer? ( dev-libs/snowball-stemmer )
+"
+DEPEND="${RDEPEND}
+       app-text/docbook-xml-dtd:4.3
+       dev-libs/libxslt
+       >=dev-util/gtk-doc-am-1.9
+       >=sys-devel/gettext-0.19.7
+"
+# ${PN} superseeds appdata-tools, require dummy package until all ebuilds
+# are migrated to appstream-glib
+RDEPEND="${RDEPEND}
+       !<dev-util/appdata-tools-0.1.8-r1
+"
+
+src_configure() {
+       gnome2_src_configure \
+               --enable-builder \
+               --enable-firmware \
+               --disable-rpm \
+               --disable-static \
+               --enable-dep11 \
+               --enable-man \
+               $(use_enable nls) \
+               $(use_enable introspection) \
+               $(use_enable stemmer) \
+               --with-bashcompletiondir="$(get_bashcompdir)"
+}