Changed warnings about not having virtual/x11 installed from eerror to ewarn for...
authorPetteri Räty <betelgeuse@gentoo.org>
Sun, 12 Mar 2006 13:35:12 +0000 (13:35 +0000)
committerPetteri Räty <betelgeuse@gentoo.org>
Sun, 12 Mar 2006 13:35:12 +0000 (13:35 +0000)
Package-Manager: portage-2.1_pre5-r4

dev-java/ibm-jdk-bin/ChangeLog
dev-java/ibm-jdk-bin/ibm-jdk-bin-1.4.2.03.ebuild
dev-java/ibm-jdk-bin/ibm-jdk-bin-1.4.2.04.ebuild
dev-java/ibm-jdk-bin/ibm-jdk-bin-1.5.0.ebuild

index 85c0bdb6a0c4bae2ec4972a385daf311a20e9aad..d90f5c789992fde142dcca380f6427610a5b407b 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for dev-java/ibm-jdk-bin
 # Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ibm-jdk-bin/ChangeLog,v 1.50 2006/02/08 22:43:29 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ibm-jdk-bin/ChangeLog,v 1.51 2006/03/12 13:35:12 betelgeuse Exp $
+
+  12 Mar 2006; Petteri Räty <betelgeuse@gentoo.org>
+  ibm-jdk-bin-1.4.2.03.ebuild, ibm-jdk-bin-1.4.2.04.ebuild,
+  ibm-jdk-bin-1.5.0.ebuild:
+  Changed warnings about not having virtual/x11 installed from eerror to ewarn
+  for bug #124258.
 
   08 Feb 2006; Saleem Abdulrasool <compnerd@gentoo.org>
   +files/ibm-jdk-bin-1.4.2.04:
index 0333c5ba6dc50b6d6bf6394b0e92e34f1e4e9427..d18bc17b3994cf17b5d2c1e8091f0d09f4af9e4b 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ibm-jdk-bin/ibm-jdk-bin-1.4.2.03.ebuild,v 1.7 2006/01/14 23:33:05 nichoj Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ibm-jdk-bin/ibm-jdk-bin-1.4.2.03.ebuild,v 1.8 2006/03/12 13:35:12 betelgeuse Exp $
 
 inherit java eutils
 
@@ -144,12 +144,12 @@ pkg_postinst() {
        java_pkg_postinst
 
        if ! use X; then
-               eerror
-               eerror "You have not enabled the X useflag.  It is possible that"
-               eerror "you do not have an X server installed.  Please note that"
-               eerror "some parts of the IBM JDK require an X server to properly"
-               eerror "function.  Be careful which Java libraries you attempt to"
-               eerror "use with your installation."
-               eerror
+               ewarn
+               ewarn "You have not enabled the X useflag.  It is possible that"
+               ewarn "you do not have an X server installed.  Please note that"
+               ewarn "some parts of the IBM JDK require an X server to properly"
+               ewarn "function.  Be careful which Java libraries you attempt to"
+               ewarn "use with your installation."
+               ewarn
        fi
 }
index 24ad392237bd1ac1bfda30df41cf9778af7cb021..c733b4d2f1c154ed1731c749ca714e9219fc7f6e 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ibm-jdk-bin/ibm-jdk-bin-1.4.2.04.ebuild,v 1.1 2006/02/08 08:22:04 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ibm-jdk-bin/ibm-jdk-bin-1.4.2.04.ebuild,v 1.2 2006/03/12 13:35:12 betelgeuse Exp $
 
 inherit java eutils
 
@@ -137,12 +137,12 @@ pkg_postinst() {
        java_pkg_postinst
 
        if ! use X; then
-               eerror
-               eerror "You have not enabled the X useflag.  It is possible that"
-               eerror "you do not have an X server installed.  Please note that"
-               eerror "some parts of the IBM JDK require an X server to properly"
-               eerror "function.  Be careful which Java libraries you attempt to"
-               eerror "use with your installation."
-               eerror
+               ewarn
+               ewarn "You have not enabled the X useflag.  It is possible that"
+               ewarn "you do not have an X server installed.  Please note that"
+               ewarn "some parts of the IBM JDK require an X server to properly"
+               ewarn "function.  Be careful which Java libraries you attempt to"
+               ewarn "use with your installation."
+               ewarn
        fi
 }
index beeeed47399a5318fc24ed02f647563310298c6a..8188c3235bf782e4eb8f0b9e4f1e8b5aa15c6606 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ibm-jdk-bin/ibm-jdk-bin-1.5.0.ebuild,v 1.4 2006/02/08 07:41:57 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ibm-jdk-bin/ibm-jdk-bin-1.5.0.ebuild,v 1.5 2006/03/12 13:35:12 betelgeuse Exp $
 
 inherit java eutils
 
@@ -103,10 +103,10 @@ pkg_postinst() {
        java_pkg_postinst
        if ! use X; then
                echo
-               eerror "You're not using X so its possible that you dont have"
-               eerror "a X server installed, please read the following warning: "
-               eerror "Some parts of IBM JDK require XFree86 to be installed."
-               eerror "Be careful which Java libraries you attempt to use."
+               ewarn "You're not using X so its possible that you dont have"
+               ewarn "a X server installed, please read the following warning: "
+               ewarn "Some parts of IBM JDK require XFree86 to be installed."
+               ewarn "Be careful which Java libraries you attempt to use."
        fi
        if ! use browserplugin && use mozilla; then
                ewarn