app-emacs/psgml: Bump to version 1.4.1.
authorUlrich Müller <ulm@gentoo.org>
Wed, 16 Oct 2019 16:58:22 +0000 (18:58 +0200)
committerUlrich Müller <ulm@gentoo.org>
Wed, 16 Oct 2019 16:58:50 +0000 (18:58 +0200)
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
app-emacs/psgml/Manifest
app-emacs/psgml/metadata.xml
app-emacs/psgml/psgml-1.4.1.ebuild [new file with mode: 0644]

index 982ef25d8889410ecb58c695a1ac3a41c5acbffe..c026b891c580f9d0039617d91d441f6bad327525 100644 (file)
@@ -1 +1,2 @@
 DIST psgml-1.4.0.tar.gz 262246 BLAKE2B e888e7e13b39108efd19bbce41f3630015556ca9e5250665456866173302b5388add506694f28a6fa7e4e4572ce4596eec66762650f7203a14d84fcfbcd8ac7f SHA512 99bab6440a0f437009edff6371412c16f47d48c6b1eaa5b894523130e3a8d604ea79dc81f1895ceecd4283d0c7fd908d4e5bdeace63e54b9ac048a80fc0f6f44
+DIST psgml-1.4.1.tar.xz 200512 BLAKE2B d2bad3e5e1d9e45f6327c064806a5c9eddc49d513bf04a0017ea3de865c3acbaec8b0b188860b4a6b435097f69e445ac92250b00b339212530cf0a7c8762b907 SHA512 bd73668341fc27dc1cecb67e4114bdb728512a35b6c834c5ad57efe4e6f3c5e0f83f9d87c55bb959cd0d9e2ec74d15d0e0ea786095bc834246e0cee646761681
index e3cf9243cef103df77f71fb6d2ca7c61f5490f7d..c918cdef959136ebef10a3a412d06b6cb9123412 100644 (file)
@@ -6,7 +6,4 @@
   <name>Gentoo GNU Emacs project</name>
 </maintainer>
 <stabilize-allarches/>
-<upstream>
-  <remote-id type="sourceforge">psgml</remote-id>
-</upstream>
 </pkgmetadata>
diff --git a/app-emacs/psgml/psgml-1.4.1.ebuild b/app-emacs/psgml/psgml-1.4.1.ebuild
new file mode 100644 (file)
index 0000000..465c0ed
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit elisp
+
+DESCRIPTION="A GNU Emacs Major Mode for editing SGML and XML coded documents"
+HOMEPAGE="https://www.emacswiki.org/emacs/PsgmlMode"
+# taken from https://marmalade-repo.org/packages/${P}.tar
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2+ Texinfo-manual"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="app-text/openjade"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+       ${EMACS} ${EMACSFLAGS} --load psgml-maint.el -f psgml-compile-files || die
+}
+
+src_install() {
+       elisp-install ${PN} *.el *.elc
+       elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+       insinto "${SITEETC}/${PN}"
+       doins *.map
+       doinfo psgml.info psgml-api.info
+       dodoc ChangeLog INSTALL README.psgml psgml.ps
+}