dev-python/os-service-types: ADD for queens
authorMatthew Thode <prometheanfire@gentoo.org>
Sat, 24 Feb 2018 04:42:52 +0000 (22:42 -0600)
committerMatthew Thode <prometheanfire@gentoo.org>
Sat, 24 Feb 2018 05:51:27 +0000 (23:51 -0600)
Package-Manager: Portage-2.3.19, Repoman-2.3.6

dev-python/os-service-types/Manifest [new file with mode: 0644]
dev-python/os-service-types/metadata.xml [new file with mode: 0644]
dev-python/os-service-types/os-service-types-1.1.0.ebuild [new file with mode: 0644]

diff --git a/dev-python/os-service-types/Manifest b/dev-python/os-service-types/Manifest
new file mode 100644 (file)
index 0000000..f2ed8cc
--- /dev/null
@@ -0,0 +1 @@
+DIST os-service-types-1.1.0.tar.gz 20838 BLAKE2B 8fbf5b5bf9d7fefcf88f51f98a6e0326bd42c0f452d614801543b45c79cc5220aeb15d4e3225c83636cb462e03914cd235942f06a367b0a4b67805c503b63d08 SHA512 d6a5e9ce633a92c61c7ca2b44e7c0bb5fb7f28efc3bdb7e240bb8c1d06f02ce1c038e11a709508dcdc4bbb8e1245297b7dafae5b49535b69359af576bb147130
diff --git a/dev-python/os-service-types/metadata.xml b/dev-python/os-service-types/metadata.xml
new file mode 100644 (file)
index 0000000..3504a7a
--- /dev/null
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="project">
+               <email>python@gentoo.org</email>
+       </maintainer>
+       <maintainer type="person">
+               <email>prometheanfire@gentoo.org</email>
+               <name>Matthew Thode</name>
+       </maintainer>
+       <longdescription lang="en">
+       </longdescription>
+       <upstream>
+               <remote-id type="github">openstack/os-service-types</remote-id>
+               <remote-id type="pypi">os-service-types</remote-id>
+       </upstream>
+</pkgmetadata>
diff --git a/dev-python/os-service-types/os-service-types-1.1.0.ebuild b/dev-python/os-service-types/os-service-types-1.1.0.ebuild
new file mode 100644 (file)
index 0000000..489c644
--- /dev/null
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+inherit distutils-r1
+
+DESCRIPTION="A library to handle official service types for OpenStack and it's aliases."
+HOMEPAGE="https://github.com/openstack/os-service-types"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+       !~dev-python/pbr-2.1.0"
+DEPEND="${CDEPEND}"
+RDEPEND="${CDEPEND}"