sys-auth/pam_ssh: Version bump to 2.2
authorDavid Seifert <soap@gentoo.org>
Sat, 19 Jan 2019 14:50:34 +0000 (15:50 +0100)
committerDavid Seifert <soap@gentoo.org>
Sat, 19 Jan 2019 14:51:34 +0000 (15:51 +0100)
Bug: https://bugs.gentoo.org/674194
Package-Manager: Portage-2.3.56, Repoman-2.3.12
Signed-off-by: David Seifert <soap@gentoo.org>
sys-auth/pam_ssh/Manifest
sys-auth/pam_ssh/pam_ssh-2.2.ebuild [new file with mode: 0644]

index 4f6c1889d98bb29931b46d32ee8322256c38bd64..84a053bb6ba6477a1649514a8d3dc9d5bec77e36 100644 (file)
@@ -1,2 +1,3 @@
 DIST pam_ssh-1.98.tar.bz2 292989 BLAKE2B 08744c6649aa58c7221e5ec07e0c6aefa8d045cf30df01b941962d29f3abdae902b0fbad37923e3ff05536e422a1062732a6998e4b58d978d369df3d866ec1aa SHA512 bf6da4ced0619549d56516c6b24e899664e0948da7a0cc04ff1b536d06cc8c26242c83eb36ed835668c824b777e270aa293162ac77e3c479311386e6e5da39ff
 DIST pam_ssh-2.1.tar.xz 361000 BLAKE2B f22836af20b41ae7254f816c33793bb3a128b604ec36a20b207610deebf61f4d5dd070fd6f5093c6f7b6eb9e14f85cd81ddbbed7e97ee581124e5335722d036b SHA512 8252b15efffa5687f740963f7a3c3479b73f99eca26a17155f915a10b9a71362a2778449adf10f01c174cc8545961ce3ea64459338a7c995c242b209529fd640
+DIST pam_ssh-2.2.tar.xz 382244 BLAKE2B b3e6122530244add64400a6c4ea9811eb6feb0309b11d9ad17d800c3ced555f5459a8dc55ec58b0649017bcce9fb12417d4ba52ab2acd3acdf5e4a0cfe956e57 SHA512 b3caeb6065b2ac925cfd1a12107902f8474badfa1770d6499508d00bf41b54497fa17080f84af9dde0b6b7692d4bd58d33d94257c3106dac7eee79ebcf3b4692
diff --git a/sys-auth/pam_ssh/pam_ssh-2.2.ebuild b/sys-auth/pam_ssh/pam_ssh-2.2.ebuild
new file mode 100644 (file)
index 0000000..8c54ab7
--- /dev/null
@@ -0,0 +1,67 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit pam flag-o-matic readme.gentoo-r1
+
+DESCRIPTION="Uses ssh-agent to provide single sign-on"
+HOMEPAGE="http://pam-ssh.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pam-ssh/${P}.tar.xz"
+
+LICENSE="BSD-2 BSD ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+# Only supports OpenSSH via `ssh-agent` #282993
+DEPEND="virtual/pam
+       dev-libs/openssl:0="
+RDEPEND="${DEPEND}
+       net-misc/openssh"
+
+PATCHES=(
+       # 503424#c5
+       "${FILESDIR}"/${PN}-2.1-dot-ssh-check.patch
+)
+
+src_configure() {
+       # hide all the otherwise-exported symbols that may clash with
+       # other software loading the PAM modules (see bug #274924 as an
+       # example).
+       append-ldflags -Wl,--version-script="${FILESDIR}"/pam_symbols.ver
+
+       # Set the cache var so the configure script doesn't go probing hardcoded
+       # file system paths and picking up the wrong thing.
+       export ac_cv_openssldir=''
+
+       # Avoid cross-compiling funkiness and requiring openssh at build time.
+       export PATH_SSH_AGENT="${EPREFIX}/usr/bin/ssh-agent"
+
+       econf \
+               "--with-pam-dir=$(getpam_mod_dir)"
+}
+
+src_install() {
+       default
+
+       # pam_ssh only builds plugins
+       find "${D}" -name '*.la' -delete || die
+
+       local DOC_CONTENTS="
+               You can enable pam_ssh for system authentication by enabling
+               the pam_ssh USE flag on sys-auth/pambase.
+       "
+       readme.gentoo_create_doc
+}
+
+pkg_preinst() {
+       if [[ ${REPLACING_VERSIONS} == 1.* ]]; then #554150
+               ewarn "Upstream pam_ssh has changed where ssh keys live.  Only keys in your"
+               ewarn "~/.ssh/login-keys.d/ will be accepted for authentication."
+       fi
+}
+
+pkg_postinst() {
+       readme.gentoo_print_elog
+}