sys-apps/ifplugd: rev bump
authorThomas Deutschmann <whissi@gentoo.org>
Sun, 3 May 2020 20:14:32 +0000 (22:14 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Sun, 3 May 2020 20:20:48 +0000 (22:20 +0200)
- Bump to EAPI 7

- Fix building against GCC 10

Thanks-to: Jeroen Roovers <jer@gentoo.org>
Closes: https://bugs.gentoo.org/706746
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
sys-apps/ifplugd/files/ifplugd-0.28-gcc10-compatibility.patch [new file with mode: 0644]
sys-apps/ifplugd/ifplugd-0.28-r11.ebuild [moved from sys-apps/ifplugd/ifplugd-0.28-r10.ebuild with 92% similarity]

diff --git a/sys-apps/ifplugd/files/ifplugd-0.28-gcc10-compatibility.patch b/sys-apps/ifplugd/files/ifplugd-0.28-gcc10-compatibility.patch
new file mode 100644 (file)
index 0000000..c87419e
--- /dev/null
@@ -0,0 +1,13 @@
+--- a/./src/interface.h
++++ b/./src/interface.h
+@@ -21,8 +21,8 @@
+  * Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
+  */
+-int interface_auto_up;
+-int interface_do_message;
++extern int interface_auto_up;
++extern int interface_do_message;
+ typedef enum { IFSTATUS_UP, IFSTATUS_DOWN, IFSTATUS_ERR } interface_status_t;
similarity index 92%
rename from sys-apps/ifplugd/ifplugd-0.28-r10.ebuild
rename to sys-apps/ifplugd/ifplugd-0.28-r11.ebuild
index 9854033e32583dac31464d5c089250b71d9c1dde..560ccc4ef8f49779b210c6eec427e6a3ba753fbf 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI="7"
 
 DESCRIPTION="Brings up/down ethernet ports automatically with cable detection"
 HOMEPAGE="http://0pointer.de/lennart/projects/ifplugd/"
@@ -25,7 +25,9 @@ PATCHES=(
        "${FILESDIR}/${P}-strictalias.patch"
        "${FILESDIR}/${P}-noip.patch"
        "${FILESDIR}/${P}-musl.patch"
-       )
+       "${FILESDIR}/${P}-gcc10-compatibility.patch"
+)
+
 DOCS=( doc/README doc/SUPPORTED_DRIVERS )
 HTML_DOCS=( doc/README.html doc/style.css )