bump for bug # 116741
authorAlec Warner <antarus@gentoo.org>
Tue, 23 Jan 2007 02:18:06 +0000 (02:18 +0000)
committerAlec Warner <antarus@gentoo.org>
Tue, 23 Jan 2007 02:18:06 +0000 (02:18 +0000)
Package-Manager: portage-2.1.1-r2

dev-util/cook/cook-2.24.ebuild
dev-util/cook/cook-2.26.ebuild [new file with mode: 0644]
dev-util/cook/files/cook-2.24-bugfix.patch [new file with mode: 0644]
dev-util/cook/files/digest-cook-2.26 [new file with mode: 0644]

index 31945e770351db3af6e152463a9439bf31a439ef..268ccb96cfa9651dbe31d6cacde1782e29f4c45a 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cook/cook-2.24.ebuild,v 1.7 2007/01/22 21:30:56 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cook/cook-2.24.ebuild,v 1.8 2007/01/23 02:18:06 antarus Exp $
 
 inherit eutils
 
@@ -18,7 +18,7 @@ DEPEND="sys-devel/bison"
 src_unpack() {
        unpack ${A}
        cd "${S}"
-       epatch "${FILESDIR}"/${P}-gcc4.patch
+       epatch "${FILESDIR}"/${P}-bugfix.patch
 }
 
 src_compile() {
diff --git a/dev-util/cook/cook-2.26.ebuild b/dev-util/cook/cook-2.26.ebuild
new file mode 100644 (file)
index 0000000..e99d397
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cook/cook-2.26.ebuild,v 1.1 2007/01/23 02:18:06 antarus Exp $
+
+inherit eutils
+
+DESCRIPTION="tool for constructing files; a drop in replacement for make"
+HOMEPAGE="http://www.canb.auug.org.au/~millerp/cook/cook.html"
+SRC_URI="http://www.canb.auug.org.au/~millerp/cook/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~ppc-macos ~sparc ~x86"
+IUSE=""
+
+DEPEND="sys-devel/bison"
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+#      epatch "${FILESDIR}"/${P}-gcc4.patch
+}
+
+src_compile() {
+       econf || die "./configure failed"
+       # doesn't seem to like parallel
+       emake -j1 || die
+}
+
+src_install() {
+       # we'll hijack the RPM_BUILD_ROOT variable which is intended for a
+       # similiar purpose anyway
+       make RPM_BUILD_ROOT="${D}" install || die
+}
diff --git a/dev-util/cook/files/cook-2.24-bugfix.patch b/dev-util/cook/files/cook-2.24-bugfix.patch
new file mode 100644 (file)
index 0000000..3206be2
--- /dev/null
@@ -0,0 +1,11 @@
+--- cook-2.24/file_check/file_check.h.orig     2005-11-05 20:22:22.000000000 +0100
++++ cook-2.24/file_check/file_check.h  2005-11-05 20:22:51.000000000 +0100
+@@ -26,7 +26,7 @@
+ #include <str.h>
+ extern int warning;
+-extern int limit;
++static int limit;
+ void file_check _((string_ty *));
diff --git a/dev-util/cook/files/digest-cook-2.26 b/dev-util/cook/files/digest-cook-2.26
new file mode 100644 (file)
index 0000000..5da3054
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 6cfae86ca89dcfcbd6483aa586a5ac72 cook-2.26.tar.gz 881301
+RMD160 8d7839f0ec484585c1db0a4763a5717d792d6513 cook-2.26.tar.gz 881301
+SHA256 59d785717af209c56cdade8d1c048b1e60a38ebccb6a4f05e815ae4104283985 cook-2.26.tar.gz 881301