dev-perl/WWW-RobotRules: EAPI6 + tests
authorKent Fredric <kentnl@gentoo.org>
Wed, 21 Mar 2018 08:28:06 +0000 (21:28 +1300)
committerKent Fredric <kentnl@gentoo.org>
Wed, 21 Mar 2018 08:28:06 +0000 (21:28 +1300)
- EAPI6ify
- Enable tests ( don't actually require internet )

Package-Manager: Portage-2.3.24, Repoman-2.3.6

dev-perl/WWW-RobotRules/WWW-RobotRules-6.20.0-r1.ebuild [new file with mode: 0644]

diff --git a/dev-perl/WWW-RobotRules/WWW-RobotRules-6.20.0-r1.ebuild b/dev-perl/WWW-RobotRules/WWW-RobotRules-6.20.0-r1.ebuild
new file mode 100644 (file)
index 0000000..171d6db
--- /dev/null
@@ -0,0 +1,19 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=GAAS
+DIST_VERSION=6.02
+inherit perl-module
+
+DESCRIPTION="Parse /robots.txt file"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+       !<dev-perl/libwww-perl-6
+       >=dev-perl/URI-1.10
+"
+DEPEND="${RDEPEND}"