Change the usage of a "class" of packages into a "set" of packages.
authorAlec Warner <antarus@gentoo.org>
Tue, 31 Jan 2006 07:43:44 +0000 (07:43 -0000)
committerAlec Warner <antarus@gentoo.org>
Tue, 31 Jan 2006 07:43:44 +0000 (07:43 -0000)
world and system are now "sets" instead of "classes".

svn path=/main/trunk/; revision=2610

man/emerge.1
man/portage.5

index 0b39ff9263b4686e7dcbfa77a1ff47ca8851c3a5..4caaa4a9fa17049444698fd4270a4b88e032f466 100644 (file)
@@ -4,7 +4,7 @@ emerge \- Command\-line interface to the Portage system
 .SH "SYNOPSIS"
 .TP
 .BR emerge
-[\fIoptions\fR] [\fIaction\fR] [\fIebuild\fR | \fItbz2file\fR | \fIclass\fR | \fIdependency\fR] ...
+[\fIoptions\fR] [\fIaction\fR] [\fIebuild\fR | \fItbz2file\fR | \fIset\fR | \fIdependency\fR] ...
 .TP
 .BR emerge
 \fB\-\-sync\fR | \fB\-\-info\fR | \fB\-\-version\fR
@@ -23,10 +23,10 @@ updated packages available.  \fBemerge\fR gracefully handles updating
 installed packages to newer releases as well.  It handles both source
 and binary packages, and it can be used to create binary packages for
 distribution.
-.SH "EBUILDS, TBZ2S, CLASSES AND DEPENDENCIES"
+.SH "EBUILDS, TBZ2S, SETS AND DEPENDENCIES"
 \fBemerge\fR primarily installs packages.  You can specify
 packages to install in one of four main ways: an \fIebuild\fR,
-a \fItbz2file\fR, a \fIclass\fR, or a \fIdependency\fR.
+a \fItbz2file\fR, a \fIset\fR, or a \fIdependency\fR.
 .LP
 .TP
 .BR ebuild
@@ -46,9 +46,9 @@ A \fItbz2file\fR must be a valid .tbz2 created with \fBebuild
 <package>\-<version>.ebuild package\fR or \fBemerge \-\-buildpkg 
 [category/]<package>\fR or \fBquickpkg /var/db/pkg/<category>/<package>\fR.
 .TP
-.BR class
-Package classes are a convenient shorthand for large groups of
-packages.  Two classes are currently supported: \fBsystem\fR
+.BR set
+Package sets are a convenient shorthand for large groups of
+packages.  Two sets are currently supported: \fBsystem\fR
 and \fBworld\fR.  \fBsystem\fR refers to a set of packages
 deemed necessary for your system to run properly.  \fBworld\fR
 contains all of the packages in \fBsystem\fR, along with any
@@ -70,7 +70,7 @@ to get around escaping problems.
 .BR "No action"
 If no action is specified, the action is to merge in the specified
 packages, satisfying any dependencies that they may have.  The
-arguments can be \fIebuilds\fR, \fItbz2s\fR, \fIclasses\fR, or
+arguments can be \fIebuilds\fR, \fItbz2s\fR, \fIsets\fR, or
 \fIdependencies\fR.  \fBNote that you need to use the \-\-usepkg 
 option if you want to install a tbz2\fR.  The packages are added
 to the \fBworld\fR file at the end, so that they are considered for
@@ -79,7 +79,7 @@ later updating.
 .BR "\-\-clean " (\fB\-c\fR)
 Cleans the system by removing packages that will not affect the
 functionality of the system.  The arguments can be \fIebuilds\fR,
-\fIclasses\fR, or \fIdependencies\fR.  For example, \fBemerge
+\fIsets\fR, or \fIdependencies\fR.  For example, \fBemerge
 clean binutils\fR cleans out old versions of binutils;
 \fBemerge \-\-clean net\-www/mozilla\-0.9.9\-r2\fR cleans out that
 specific version of Mozilla.  This is generally safe to use.
@@ -133,7 +133,7 @@ handle multiple versions of the same package properly, beware!  This does not
 check dependencies, so it may also remove packages necessary for the proper 
 operation of your system.  \fBUse\fR \-\-clean \fBinstead unless you really 
 know what you're doing\fR.  Its arguments can be \fIebuilds\fR, 
-\fIclasses\fR, or \fIdependencies\fR \-\- see \fB\-\-clean\fR above for 
+\fIsets\fR, or \fIdependencies\fR \-\- see \fB\-\-clean\fR above for 
 examples.  You have been warned!
 .TP
 .BR \-\-regen
@@ -177,7 +177,7 @@ description of PORTDIR_OVERLAY for a method to avoid deletions.
 \fBWARNING: This action can remove important packages!\fR Removes
 all matching packages.  This does no checking of dependencies, so
 it may remove packages necessary for the proper operation of your
-system.  Its arguments can be \fIebuilds\fR, \fIclasses\fR, or
+system.  Its arguments can be \fIebuilds\fR, \fIsets\fR, or
 \fIdependencies\fR \-\- see \fB\-\-clean\fR above for examples.
 .TP
 .BR "\-\-update " (\fB\-u\fR)
@@ -437,7 +437,7 @@ displayed.
 You should almost always precede any package install or update attempt with a 
 \fB\-\-pretend\fR install or update.  This lets you see how much will be 
 done, and shows you any blocking packages that you will have to rectify.  
-This goes doubly so for the \fBsystem\fR and \fBworld\fR classes, which can 
+This goes doubly so for the \fBsystem\fR and \fBworld\fR sets, which can 
 update a large number of packages if the portage tree has been particularly 
 active.
 .LP
@@ -517,7 +517,7 @@ Marius Mauch <genone@gentoo.org>
 \fB/var/lib/portage/world\fR 
 Contains a list of all user\-specified packages.  You can safely edit
 this file, adding packages that you want to be considered in \fBworld\fR
-class updates and removing those that you do not want to be considered.
+set updates and removing those that you do not want to be considered.
 .TP
 \fB/etc/make.conf\fR 
 Contains variables for the build process, overriding those in
@@ -546,7 +546,7 @@ Contains a list of default packages used to resolve virtual dependencies.
 .TP
 \fB/etc/make.profile/packages\fR
 Contains a list of packages used for the base system.  The \fBsystem\fR
-and \fBworld\fR classes consult this file.  \fBDo not edit this file\fR.
+and \fBworld\fR sets consult this file.  \fBDo not edit this file\fR.
 .TP
 \fB/etc/make.globals\fR 
 Contains the default variables for the build process.  \fBDo not edit
index ab1fc03180b996e82a53b734fffdf23685351116..b53532445274eaeb815507f790982ece4a0b00d7 100644 (file)
@@ -162,13 +162,13 @@ Special USE flags used by catalyst for building a stage3 and GRP sets.
 .BR packages
 This file serves two purposes.  The first is to mask out specific 
 packages/versions on a per\-profile basis.  The second is to provide the 
-list of packages that compose the special \fIsystem\fR class.
+list of packages that compose the special \fIsystem\fR set.
 
 .I Format:
 .nf
 \- comments begin with #
 \- one DEPEND atom per line of what to mask OUT
-\- packages to be added to the system class begin with a *
+\- packages to be added to the system set begin with a *
 .fi
 .I Note:
 In a cascading profile setup, you can remove packages in children 
@@ -180,10 +180,10 @@ a '\-'.
 # i am a comment !
 # only allow versions of glibc less than 2.3
 <sys\-libs/glibc\-2.3
-# add any version of bash to the system class
+# add any version of bash to the system set
 *app\-shells/bash
 # only allow versions of readline earlier than 4.2
-# and add it to the system class
+# and add it to the system set
 *<sys\-libs/readline\-4.2
 .fi
 .TP