app-editors/ee: fix build with >=sys-devel/gcc-10
authorAkinori Hattori <hattya@gentoo.org>
Sun, 10 May 2020 09:31:10 +0000 (18:31 +0900)
committerAkinori Hattori <hattya@gentoo.org>
Sun, 10 May 2020 09:32:00 +0000 (18:32 +0900)
Closes: https://bugs.gentoo.org/706538
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Akinori Hattori <hattya@gentoo.org>
app-editors/ee/ee-1.5.2.ebuild
app-editors/ee/files/ee-gcc-10.patch [new file with mode: 0644]

index 832cb1b3e8fa7bcf4de4f8de97706499724a5cbc..ad4bb78c8530122307bd274e84533d337ef29cde 100644 (file)
@@ -22,6 +22,7 @@ PATCHES=(
        "${FILESDIR}"/${PN}-init-location.patch
        "${FILESDIR}"/${PN}-signal.patch
        "${FILESDIR}"/${PN}-Wformat-security.patch
+       "${FILESDIR}"/${PN}-gcc-10.patch
 )
 DOCS=( Changes README.${PN} ${PN}.i18n.guide ${PN}.msg )
 
diff --git a/app-editors/ee/files/ee-gcc-10.patch b/app-editors/ee/files/ee-gcc-10.patch
new file mode 100644 (file)
index 0000000..2577d76
--- /dev/null
@@ -0,0 +1,22 @@
+--- a/new_curse.c
++++ b/new_curse.c
+@@ -83,6 +83,8 @@
+ #endif
++struct _line *top_of_win;
++
+ WINDOW *curscr;
+ static WINDOW *virtual_scr;
+ WINDOW *stdscr;
+--- a/new_curse.h
++++ b/new_curse.h
+@@ -161,7 +161,7 @@
+       int number;
+       };
+-struct _line *top_of_win;
++extern struct _line *top_of_win;
+ typedef struct WIND {
+       int SR;         /* starting row         */