Version bump to 2.0_rc47 and closing bug #135051 and bug #135971.
authorChris Gianelloni <wolf31o2@gentoo.org>
Fri, 9 Jun 2006 00:49:16 +0000 (00:49 +0000)
committerChris Gianelloni <wolf31o2@gentoo.org>
Fri, 9 Jun 2006 00:49:16 +0000 (00:49 +0000)
Package-Manager: portage-2.1_rc4-r3

dev-util/catalyst/ChangeLog
dev-util/catalyst/catalyst-2.0_rc47.ebuild [new file with mode: 0644]
dev-util/catalyst/files/catalyst-2.0_rc47-slot.patch [new file with mode: 0644]
dev-util/catalyst/files/digest-catalyst-2.0_rc47 [new file with mode: 0644]

index cfbf6720f4e7ca14ebd56ec847cb4a033560ee0d..cb57bf0a321524374f9645b3cffc4d487a91d793 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for dev-util/catalyst
 # Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.149 2006/05/25 16:31:39 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/ChangeLog,v 1.150 2006/06/09 00:49:16 wolf31o2 Exp $
+
+*catalyst-2.0_rc47 (09 Jun 2006)
+
+  09 Jun 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+  -files/catalyst-2.0_rc46-slot.patch, +files/catalyst-2.0_rc47-slot.patch,
+  -catalyst-2.0_rc46.ebuild, +catalyst-2.0_rc47.ebuild:
+  Version bump to 2.0_rc47 and closing bug #135051 and bug #135971.
 
 *catalyst-2.0_rc46 (25 May 2006)
 
diff --git a/dev-util/catalyst/catalyst-2.0_rc47.ebuild b/dev-util/catalyst/catalyst-2.0_rc47.ebuild
new file mode 100644 (file)
index 0000000..1c04a0e
--- /dev/null
@@ -0,0 +1,95 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catalyst/catalyst-2.0_rc47.ebuild,v 1.1 2006/06/09 00:49:16 wolf31o2 Exp $
+
+inherit eutils
+
+DESCRIPTION="Gentoo Linux official release metatool"
+HOMEPAGE="http://www.gentoo.org/proj/en/releng/catalyst"
+SRC_URI="http://dev.gentoo.org/~wolf31o2/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="2.0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="ccache cdr"
+
+DEPEND=""
+RDEPEND="dev-lang/python
+       app-crypt/shash
+       amd64? ( sys-apps/setarch )
+       ppc64? ( sys-apps/setarch )
+       ccache? ( dev-util/ccache )
+       cdr? (
+               virtual/cdrtools
+               ia64? ( sys-fs/dosfstools )
+               app-misc/zisofs-tools
+               >=sys-fs/squashfs-tools-2.1 )"
+#      examples? (
+#              dev-util/livecd-kconfigs
+#              dev-util/livecd-specs )"
+
+pkg_setup() {
+       if use ccache ; then
+               einfo "Enabling ccache support for catalyst."
+       else
+               ewarn "By default, ccache support for catalyst is disabled."
+               ewarn "If this is not what you intended,"
+               ewarn "then you should add ccache to your USE."
+       fi
+       echo
+       einfo "The template spec files are now installed by default.  You can find"
+       einfo "them under /usr/share/doc/${PF}/examples"
+       einfo "and they are considered to be the authorative source of information"
+       einfo "on catalyst."
+}
+
+src_unpack() {
+       unpack ${A}
+       epatch "${FILESDIR}"/${P}-slot.patch
+}
+
+src_install() {
+       ewarn "This version of the ebuild is slotted to allow side-by-side"
+       ewarn "installation with catalyst 1.x for use on build servers.  The final"
+       ewarn "version of this ebuild will not be slotted, as catalyst 2.0 is to"
+       ewarn "supercede catalyst 1.x in every way.  It is currently slotted for"
+       ewarn "testing purposes only."
+       insinto /usr/lib/${PN}2/arch
+       doins arch/* || die "copying arch/*"
+       insinto /usr/lib/${PN}2/modules
+       doins modules/* || die "copying modules/*"
+       insinto /usr/lib/${PN}2/livecd/cdtar
+       doins livecd/cdtar/* || die "copying cdtar/*"
+       insinto /usr/lib/${PN}2/livecd/files
+       doins livecd/files/* || die "copying files/*"
+       for x in targets/*; do
+               exeinto /usr/lib/${PN}2/$x
+               doexe $x/* || die "copying ${x}"
+       done
+       exeinto /usr/lib/${PN}2
+       newexe catalyst catalyst2 || die "copying catalyst"
+       dodir /usr/bin
+       dosym /usr/lib/${PN}2/catalyst2 /usr/bin/catalyst2
+       insinto /etc/catalyst2
+       newins files/catalyst.conf catalyst2.conf
+       DOCDESTTREE="." dohtml -A spec,msg,example -r examples files
+       dodoc README ChangeLog ChangeLog.old AUTHORS
+       newman files/catalyst.1 catalyst2.1
+       # This will go away in the future
+       dosed "s:/usr/lib/catalyst:/usr/lib/catalyst2:" \
+               /etc/catalyst2/catalyst2.conf
+       dosed "s:/var/tmp/catalyst:/var/tmp/catalyst2:" \
+               /etc/catalyst2/catalyst2.conf
+       # Here is where we actually enable ccache
+       use ccache && \
+               dosed 's:options="autoresume kern:options="autoresume ccache kern:' \
+               /etc/catalyst2/catalyst2.conf
+}
+
+pkg_postinst() {
+       echo
+       einfo "You can find more information about catalyst by checking out the"
+       einfo "catalyst project page at:"
+       einfo "http://www.gentoo.org/proj/en/releng/catalyst/index.xml"
+       echo
+}
diff --git a/dev-util/catalyst/files/catalyst-2.0_rc47-slot.patch b/dev-util/catalyst/files/catalyst-2.0_rc47-slot.patch
new file mode 100644 (file)
index 0000000..71f69b7
--- /dev/null
@@ -0,0 +1,30 @@
+diff -urN catalyst-2.0_rc47.orig/catalyst catalyst-2.0_rc44/catalyst
+--- catalyst-2.0_rc47.orig/catalyst    2005-12-20 07:07:45.000000000 -0500
++++ catalyst-2.0_rc47/catalyst 2005-12-20 07:09:19.000000000 -0500
+@@ -51,10 +51,10 @@
+       myconf={}
+       config_file=""
+-      confdefaults={ "storedir":"/var/tmp/catalyst",\
+-              "sharedir":"/usr/share/catalyst","distdir":"/usr/portage/distfiles",\
++      confdefaults={ "storedir":"/var/tmp/catalyst2",\
++              "sharedir":"/usr/share/catalyst2","distdir":"/usr/portage/distfiles",\
+               "portdir":"/usr/portage","options":"",\
+-              "snapshot_cache":"/var/tmp/catalyst/snapshot_cache",\
++              "snapshot_cache":"/var/tmp/catalyst2/snapshot_cache",\
+               "hash_function":"crc32"}
+               
+       # first, try the one passed (presumably from the cmdline)
+@@ -69,9 +69,9 @@
+                       sys.exit(1)
+       
+       # next, try the default location
+-      elif os.path.exists("/etc/catalyst/catalyst.conf"):
+-              print "Using default Catalyst configuration file, /etc/catalyst/catalyst.conf"
+-              config_file="/etc/catalyst/catalyst.conf"
++      elif os.path.exists("/etc/catalyst2/catalyst2.conf"):
++              print "Using default Catalyst configuration file, /etc/catalyst2/catalyst2.conf"
++              config_file="/etc/catalyst2/catalyst2.conf"
+       
+       # can't find a config file (we are screwed), so bail out
+       else:
diff --git a/dev-util/catalyst/files/digest-catalyst-2.0_rc47 b/dev-util/catalyst/files/digest-catalyst-2.0_rc47
new file mode 100644 (file)
index 0000000..4edf03d
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 6b2666dec2ab7aab3290655eb714f392 catalyst-2.0_rc47.tar.bz2 865250
+RMD160 91af2ce861e35f7401630e35a15c96687e8fdbcd catalyst-2.0_rc47.tar.bz2 865250
+SHA256 1b0942b782c0f20e9668dbbe1b20eed983f07693238020d6c5c1494209228a8c catalyst-2.0_rc47.tar.bz2 865250