app-office/impressive: Bump to 0.13.0beta1 supporting python3
authorPacho Ramos <pacho@gentoo.org>
Wed, 25 Dec 2019 15:43:37 +0000 (16:43 +0100)
committerPacho Ramos <pacho@gentoo.org>
Wed, 25 Dec 2019 16:57:14 +0000 (17:57 +0100)
Disable python2 support to not rely on a pygame python2 version relying on
dead numpy-python2

Bug: https://bugs.gentoo.org/703758
Package-Manager: Portage-2.3.82, Repoman-2.3.20
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
app-office/impressive/Manifest
app-office/impressive/impressive-0.13.0_beta1.ebuild [new file with mode: 0644]

index ca8bf9e9161b20a638f45490fcbffd850cd08fe9..a9d254987d0aa9f6c9fb68ece5361b630abb7dd9 100644 (file)
@@ -1,2 +1,3 @@
 DIST Impressive-0.11.2.tar.gz 198391 BLAKE2B e0157a910b61c7dbe0796193b3d18f533210de50568d835e5204a848a5ac4978ab228b633d5137fb068af09a88d0c50fc2dbbb02b9b0d1a32a99f9de220ac1de SHA512 cabb52612f65ddadfb080e3db6417680a1aa9724fe45d8b78a1206b6508a8b60c5e5a7c218ff0f90e62adcd498aabe625837164fc547604dfd7aba425db87dd6
 DIST Impressive-0.12.0.tar.gz 209514 BLAKE2B aef0c793c85c680c65399cfcef56488c558ec49a8246d55bacc05a2e1fa0de51d548ddcf67788d36a4de91d62495a623269976345f99d63d25f3ae8bc9efdbd8 SHA512 3425d9d53c8c3ff6d5de0a3466bbf5c94f257390b4929ba12547ba930099de67db4f4d77d4ef4e3e10f8f723478569a74042553f64cf95e236931c7aabb70f0a
+DIST Impressive-0.13.0-beta1a.tar.gz 213098 BLAKE2B c76ce023f9c44865db68d1d2049aba022581d5e62cf027cc4df63ae541a8471867e75749a2f72c8e1f9e2e7ca2640611e090080ac563cff54f521ea47a351304 SHA512 5484f9764848129150d03233a9b270d2c31ec5f5083100662dd3cca85d3c7ead0000bd23b7d531ad45667410e1a1ea5d97ca1a2f4e8a2449dc730273144e56e8
diff --git a/app-office/impressive/impressive-0.13.0_beta1.ebuild b/app-office/impressive/impressive-0.13.0_beta1.ebuild
new file mode 100644 (file)
index 0000000..f1f11ad
--- /dev/null
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit eutils python-r1
+
+MY_PN="Impressive"
+
+DESCRIPTION="Stylish way of giving presentations with Python"
+HOMEPAGE="http://impressive.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}/${PV/_/-}/${MY_PN}-${PV/_/-}a.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND=""
+RDEPEND="${PYTHON_DEPS}
+       dev-python/pygame[${PYTHON_USEDEP}]
+       dev-python/pillow[${PYTHON_USEDEP}]
+       x11-apps/xrandr
+       app-text/mupdf
+       || ( media-fonts/dejavu media-fonts/corefonts )
+"
+
+DOCS=(
+       changelog.txt
+       demo.pdf
+)
+HTML_DOCS=(
+       impressive.html
+)
+
+S="${WORKDIR}/${MY_PN}-${PV/_/-}a"
+
+src_install() {
+       default
+       python_foreach_impl python_doscript ${PN}.py
+       doman impressive.1
+}
+
+pkg_postinst() {
+       elog "The experience with ${PN} can be enhanced by folowing packages:"
+       optfeature "starting web or e-mail hyperlinks from PDF documents" x11-misc/xdg-utils
+       optfeature "sound and video playback" media-video/ffmpeg
+       optfeature "sound and video playback" media-video/mplayer
+       optfeature "sound and video playback" media-video/mplayer2
+       optfeature "extraction of PDF page titles" app-text/pdftk
+}