dev-java/jdbc-postgresql: Version bump github/pr/115
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>
Mon, 21 Sep 2015 23:48:18 +0000 (01:48 +0200)
committerAndreas Sturmlechner <andreas.sturmlechner@gmail.com>
Mon, 21 Sep 2015 23:48:18 +0000 (01:48 +0200)
See also:
https://jdbc.postgresql.org/documentation/changelog.html#version_9.4-1203

Package-Manager: portage-2.2.20.1

dev-java/jdbc-postgresql/Manifest
dev-java/jdbc-postgresql/jdbc-postgresql-9.4_p1203.ebuild [new file with mode: 0644]

index 0ace2c64127575414024bfc7d898f4962f21ebe2..35e4d379c5009ec6cc6bd5da43302c5b8bf958ca 100644 (file)
@@ -4,3 +4,4 @@ DIST postgresql-jdbc-9.2-1003.src.tar.gz 1843082 SHA256 d61449b8a17ce540b2643738
 DIST postgresql-jdbc-9.2-1004.src.tar.gz 1842921 SHA256 eeadff0d830cd19a4f52a9489748a7126b0c1d4863bf9a5d65618158dfc6ae68 SHA512 6e218b7df3d772e4fb9053672f5f77f6012fe6e652a536dfe171408e957465520b05994d4fa13c4d478b595a55b8068da663b9f3dcb544a46fcf91d71ba8fdf5 WHIRLPOOL f1afa3201fbaaf47edb0224d3263642b3202fbf6fc922318354db86e394f0005611b0981da043a4e14cbb67224ac8fa6d96880e0763fcd4d5b502423c7eaa0c7
 DIST postgresql-jdbc-9.3-1100.src.tar.gz 1852465 SHA256 e6be53d4cda04735f5f147d2296acb9a22630b062fa3a4ef894073f23efc6d55 SHA512 43968a62f9443739721016ede186b2f41fa6db2d1ef319cd65059f8715e90eda7c7f568995b293578c39e04d43085cfdfece587500f99ed1a49964c12d8c747a WHIRLPOOL 9bf218936a00df00fb4b4f6ed6c3bbe06cdcfcd14d306a4f7bf3073e83f1c51bc85c0a061c2e04790bcebf9183b8aabd056522fa5d18b0734a4aec34b3ab14a0
 DIST postgresql-jdbc-9.4-1201.src.tar.gz 1909810 SHA256 96b079611038c0ffff6bb8d22d51ada0cb82c8eb3bd3a9294055963cc638fda7 SHA512 6fd543e325de931ee6c33fe4b1daf53d7baa91061afc9dc1687c4b202430cbcf2a7e3fb047f9e1d88f4d39b8f4f85a98f2b930205ceba414212dfcbaaf108883 WHIRLPOOL 3245227c875d44d82109a5700e06ed3d5bcc75469cd9333c98a7b396b2db1e2ac1da002db19f632afed262929cd7e9a3d8f93d2b24321e103b815383f8fc0a05
+DIST postgresql-jdbc-9.4-1203.src.tar.gz 1909858 SHA256 ce2fd309778d9453f012fa85c99071b42cbd62f3ce06d53a4b8aaeb53ac51322 SHA512 9ac059714fb411cf52b1a03ce4991179cc032f17060e733c454f0e41bd8da64c64e718ec131a7d875e334719fd572452c77dbed9ba119eca6cf2f066a3511013 WHIRLPOOL c8581872dfe1495deef2335def51e54d7094c26c6034f26220a63bb657c452181ba996fd6def975d7532dc87a7dba49dd8111c07f9c8e9823917988fd36c9609
diff --git a/dev-java/jdbc-postgresql/jdbc-postgresql-9.4_p1203.ebuild b/dev-java/jdbc-postgresql/jdbc-postgresql-9.4_p1203.ebuild
new file mode 100644 (file)
index 0000000..43486b5
--- /dev/null
@@ -0,0 +1,100 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+MY_PN="postgresql-jdbc"
+MY_PV="${PV/_p/-}"
+MY_P="${MY_PN}-${MY_PV}.src"
+
+DESCRIPTION="JDBC Driver for PostgreSQL"
+SRC_URI="http://jdbc.postgresql.org/download/${MY_P}.tar.gz"
+HOMEPAGE="http://jdbc.postgresql.org/"
+
+LICENSE="POSTGRESQL"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+DEPEND="
+       >=virtual/jdk-1.6
+       doc? (
+               dev-libs/libxslt
+               app-text/docbook-xsl-stylesheets
+       )
+       test? (
+               dev-java/ant-junit
+               dev-java/junit:4
+               >=dev-db/postgresql-9.3[server]
+       )"
+RDEPEND=">=virtual/jre-1.6"
+
+S="${WORKDIR}/postgresql-jdbc-${MY_PV}.src"
+
+java_prepare() {
+       find -name "*.class" -type f -exec rm -v {} + || die
+
+       # Strip build.xml of maven deps
+       sed -i -e '/<classpath.*dependency\.compile\.classpath/c\' build.xml || die
+       sed -i -e '/<classpath.*dependency\.runtime\.classpath/c\' build.xml || die
+       sed -i -e '/<classpath.*dependency\.test\.classpath/c\' build.xml || die
+       sed -i -e '/<target name="artifact-version"/,/<[/]target>/{s/depends="maven-dependencies"//}' build.xml || die
+       sed -i -e '/<target name="compile"/ s/,maven-dependencies//' build.xml || die
+
+       # Remove SSPI, it pulls in Waffle-JNA and is only used on Windows
+       sed -i -e '/<include.*sspi/c\' build.xml || die
+       rm -vrf org/postgresql/sspi || die "Error removing sspi"
+       epatch "${FILESDIR}"/${PN}-9.4_p1201-remove-sspi.patch
+
+       # FIXME @someone who cares: enable through osgi flag?
+       sed -i -e '/<include.*osgi/c\' build.xml || die
+       sed -i -e '/<test.*osgi/c\' build.xml || die
+       rm -vrf org/postgresql/osgi || die "Error removing osgi"
+       rm -vrf org/postgresql/test/osgi || die "Error removing osgi tests"
+       epatch "${FILESDIR}"/${PN}-9.4_p1201-remove-osgi.patch
+}
+
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+EANT_DOC_TARGET="publicapi"
+
+src_compile() {
+       EANT_BUILD_TARGET="release-version jar"
+       java-pkg-2_src_compile
+
+       # There is a task that creates this doc but I didn't find a way how to use system catalog
+       # to lookup the stylesheet so the 'doc' target is rewritten here to use system call instead.
+       if use doc; then
+               mkdir -p "${S}/build/doc"
+               xsltproc -o "${S}/build/doc/pgjdbc.html" http://docbook.sourceforge.net/release/xsl/current/xhtml/docbook.xsl \
+                       "${S}/doc/pgjdbc.xml"
+       fi
+}
+
+src_test() {
+       einfo "In order to run the tests successfully, you have to have:"
+       einfo "1) PostgreSQL server running"
+       einfo "2) database 'test' defined with user 'test' with password 'test'"
+       einfo "   as owner of the database"
+       einfo "3) plpgsql support in the 'test' database"
+       einfo
+       einfo "You can find a general info on how to perform these steps at"
+       einfo "https://wiki.gentoo.org/wiki/PostgreSQL"
+
+       ANT_TASKS="ant-junit" eant test -Dgentoo.classpath=$(java-pkg_getjars --build-only junit-4)
+}
+
+src_install() {
+       java-pkg_newjar build/jars/postgresql*.jar jdbc-postgresql.jar
+
+       if use doc ; then
+               java-pkg_dojavadoc build/publicapi
+               dohtml build/doc/pgjdbc.html
+       fi
+
+       use source && java-pkg_dosrc org
+}