sys-devel/prelink: Update dependencies.
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>
Mon, 6 Apr 2020 01:06:13 +0000 (01:06 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Mon, 6 Apr 2020 20:30:39 +0000 (21:30 +0100)
Closes: https://bugs.gentoo.org/716398
Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
sys-devel/prelink/prelink-20151030.ebuild
sys-devel/prelink/prelink-99999999.ebuild

index ff8cc4445742b37c758f4ba9226710a958aa2c2f..6c1b59681b7bb14b1d2f96e650cdbe72c9b01799 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 2002-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="5"
@@ -18,13 +18,11 @@ SLOT="0"
 KEYWORDS="amd64 ~arm ppc ppc64 x86"
 IUSE="doc selinux"
 
-DEPEND=">=dev-libs/elfutils-0.100[static-libs(+)]
-       selinux? ( sys-libs/libselinux[static-libs(+)] )
-       !dev-libs/libelf
-       sys-libs/binutils-libs
-       >=sys-libs/glibc-2.8"
-RDEPEND="${DEPEND}
-       >=sys-devel/binutils-2.18"
+RDEPEND=">=dev-libs/elfutils-0.100
+       selinux? ( sys-libs/libselinux )
+       !dev-libs/libelf"
+DEPEND="${RDEPEND}
+       sys-libs/binutils-libs"
 
 S=${WORKDIR}/${MY_P}
 
index 390d0c35e0cd55a57da2c9ecc268342c03c15910..4088e323d9bc6b18b682c48d1a6d66e7a85882cf 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 2002-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="7"
@@ -16,13 +16,11 @@ LICENSE="GPL-2"
 SLOT="0"
 IUSE="doc selinux"
 
-DEPEND="selinux? ( sys-libs/libselinux[static-libs(+)] )
-       !dev-libs/libelf
-       sys-libs/binutils-libs
-       >=sys-libs/glibc-2.8"
-RDEPEND="${DEPEND}
-       >=sys-devel/binutils-2.18
-       >=dev-libs/elfutils-0.100[static-libs(+)]"
+RDEPEND=">=dev-libs/elfutils-0.100
+       selinux? ( sys-libs/libselinux )
+       !dev-libs/libelf"
+DEPEND="${RDEPEND}
+       sys-libs/binutils-libs"
 
 PATCHES=(
        "${FILESDIR}"/${PN}-20130503-prelink-conf.patch