dev-python/keyring: Port to py39
authorMichał Górny <mgorny@gentoo.org>
Wed, 27 May 2020 05:47:10 +0000 (07:47 +0200)
committerMichał Górny <mgorny@gentoo.org>
Wed, 27 May 2020 06:10:55 +0000 (08:10 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/keyring/keyring-19.3.0.ebuild

index d9dbd7b1f35afa622b9e9c0e22e89b631f51987c..448afd7a7d74e5d41f5e6b89075dfb4f413cb20a 100644 (file)
@@ -3,7 +3,8 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( pypy3 python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( pypy3 python3_{6,7,8,9} )
 
 inherit distutils-r1
 
@@ -14,19 +15,13 @@ SRC_URI="https://github.com/jaraco/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
 SLOT="0"
 LICENSE="PSF-2"
 KEYWORDS="~alpha amd64 ~arm ~arm64 x86"
-IUSE="doc test"
+IUSE="doc"
 
 RDEPEND="
        dev-python/secretstorage[${PYTHON_USEDEP}]
        dev-python/entrypoints[${PYTHON_USEDEP}]
        $(python_gen_cond_dep 'dev-python/importlib_metadata[${PYTHON_USEDEP}]' pypy3 python3_{5,6,7})
 "
-BDEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? ( ${RDEPEND} )
-"
-
-RESTRICT="!test? ( test )"
 
 PATCHES=(
        "${FILESDIR}/keyring-19.1.0-tests.patch"