gnome-extra/gnome-color-manager: Version bump
authorPacho Ramos <pacho@gentoo.org>
Sun, 15 Nov 2015 09:35:29 +0000 (10:35 +0100)
committerPacho Ramos <pacho@gentoo.org>
Sun, 15 Nov 2015 10:29:43 +0000 (11:29 +0100)
Package-Manager: portage-2.2.24

gnome-extra/gnome-color-manager/Manifest
gnome-extra/gnome-color-manager/gnome-color-manager-3.18.0.ebuild [new file with mode: 0644]

index 9b9981a3b985722a4f8e6936d84a5a49bdc9e56b..ad4919895d6dab9f115aa76a6ca98918dd89b562 100644 (file)
@@ -1,3 +1,4 @@
 DIST gnome-color-manager-3.12.3.tar.xz 2618564 SHA256 ce62f9d2d8702547b5083f800a2747cb6c8fd5a04a71e2dc6928166951d1d039 SHA512 991f2e98f60255ad28fb05d616ea0ac970cdc51558bd33ded5a89ab792f5c807f689c1a3ca4de4ae260a5e399afe75dac7c05b897423bf9a1052533452b8f555 WHIRLPOOL e310e478c93b158f21606e36b17e00f86ddfff05ff86655404fdccd88c43cf29ed96de0a731cb70ec29d440cc3bc3a43461767b25942cdfffba5ef3af80aec1e
 DIST gnome-color-manager-3.14.2.tar.xz 2630640 SHA256 a2fa17f17c1c7259dbf6f042b7adf2816a7ba54747706e1b245bcd6d6274eeef SHA512 662a35a841c410cedcb797187ceb6fa2abf2329822dd787d4c97aa97225d7a31899551f9425c59b7bc0a4f426c9f908d8d3d02c1111691991a92c42923df39af WHIRLPOOL c4a171baa678c9f5075c5d490fd72122ad9b92a19405dd7e770f2b311bab1d23256e7b9ce15d72e3f7dda703692076ed1318cb9cc108c96f3a3121fc9ad7b885
 DIST gnome-color-manager-3.16.0.tar.xz 2632592 SHA256 408890ae1d15cff6385b61b61e1a2de0b4236ef706eddd96181b227fda1daf0f SHA512 cdd6c2170d3335610cc32250ccd6c214e700e5f27d211757730e1b3a794d6651ec3b06bbae3b3e2782a784c175b4666d3b4761b47ebaecced84667d6c8dbaa4d WHIRLPOOL fd51703609f4a6d7125cc07c08cf96b0cf0d206a7299996d5885c4494f2311d2a2f2c9bb494007440f9beecb43a96d0d73561091f69e52368dfc740c269c3215
+DIST gnome-color-manager-3.18.0.tar.xz 2647648 SHA256 83d06f3b76b89b6c56bd6e4f792e15c67b561682fa9d59b60cbf716f6130a435 SHA512 4f1259681ee5f3762b1e4212e7b48c2caaa371d5cec00aa1ee4506f908310c8bbe4ff3e05e857707573475bfae0e61364d72c2d942d1d3fe5d978d2ca02c627c WHIRLPOOL 24e90187d17591450ac23da6afce3736e9380c2be75f0e3e7c470cebd5c849e8a40adf697cf42cc9269c419190379395d450fbe4a60eace40e16fe5ecf3ad8ae
diff --git a/gnome-extra/gnome-color-manager/gnome-color-manager-3.18.0.ebuild b/gnome-extra/gnome-color-manager/gnome-color-manager-3.18.0.ebuild
new file mode 100644 (file)
index 0000000..c7fb283
--- /dev/null
@@ -0,0 +1,69 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2 virtualx
+
+DESCRIPTION="Color profile manager for the GNOME desktop"
+HOMEPAGE="https://git.gnome.org/browse/gnome-color-manager"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="packagekit raw"
+
+# Need gtk+-3.3.8 for https://bugzilla.gnome.org/show_bug.cgi?id=673331
+COMMON_DEPEND="
+       >=dev-libs/glib-2.31.10:2
+       >=media-libs/lcms-2.2:2
+       >=media-libs/libcanberra-0.10[gtk3]
+       media-libs/libexif
+       media-libs/tiff:0=
+
+       >=x11-libs/gtk+-3.3.8:3
+       >=x11-libs/vte-0.25.1:2.91
+       >=x11-misc/colord-0.1.34:0=
+       >=x11-libs/colord-gtk-0.1.20
+
+       packagekit? ( app-admin/packagekit-base )
+       raw? ( media-gfx/exiv2 )
+"
+RDEPEND="${COMMON_DEPEND}"
+
+# docbook-sgml-{utils,dtd:4.1} needed to generate man pages
+DEPEND="${COMMON_DEPEND}
+       app-text/docbook-sgml-dtd:4.1
+       app-text/docbook-sgml-utils
+       dev-libs/appstream-glib
+       dev-libs/libxslt
+       >=dev-util/intltool-0.35
+       dev-util/itstool
+       virtual/pkgconfig
+"
+
+src_configure() {
+       # Always enable tests since they are check_PROGRAMS anyway
+       # appstream does not want to be relax by default !
+       gnome2_src_configure \
+               --disable-static \
+               --enable-tests \
+               $(use_enable packagekit) \
+               $(use_enable raw exiv) \
+               APPSTREAM_UTIL=$(type -P true)
+}
+
+src_test() {
+       Xemake check
+}
+
+pkg_postinst() {
+       gnome2_pkg_postinst
+
+       if ! has_version media-gfx/argyllcms ; then
+               elog "If you want to do display or scanner calibration, you will need to"
+               elog "install media-gfx/argyllcms"
+       fi
+}