media-video/submux-dvd: Bump to EAPI 7
authorMichał Górny <mgorny@gentoo.org>
Sat, 9 Nov 2019 18:50:09 +0000 (19:50 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 9 Nov 2019 19:11:14 +0000 (20:11 +0100)
Closes: https://bugs.gentoo.org/697260
Signed-off-by: Michał Górny <mgorny@gentoo.org>
media-video/submux-dvd/submux-dvd-0.5.2-r1.ebuild [moved from media-video/submux-dvd/submux-dvd-0.5.2.ebuild with 57% similarity]

similarity index 57%
rename from media-video/submux-dvd/submux-dvd-0.5.2.ebuild
rename to media-video/submux-dvd/submux-dvd-0.5.2-r1.ebuild
index 777bfdb2064780bdd09a948bdb82be7e9bb3e4e9..b885b0ecf4738ea3b6152ef9315619328c13f01a 100644 (file)
@@ -1,29 +1,25 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
+EAPI=7
 
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
 
 DESCRIPTION="A subtitle multiplexer, muxes subtitles into .vob"
 HOMEPAGE="http://panteltje.com/panteltje/dvd/"
 SRC_URI="http://panteltje.com/panteltje/dvd/${P}.tgz"
 
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
 SLOT="0"
 KEYWORDS="~amd64 ~ppc ~x86"
 IUSE=""
 
-DEPEND=""
-RDEPEND="${DEPEND}"
-
 src_compile() {
-       emake CC="$(tc-getCC)" || die
+       emake CC="$(tc-getCC)"
 }
 
 src_install() {
        # just 2 files not worth a makefile patch
-       dobin submux-dvd vob2sub || die
-       dodoc CHANGES FORMAT INSTALL README ${P}.lsm || die
-       dohtml spu.html || die
+       dobin submux-dvd vob2sub
+       dodoc CHANGES FORMAT INSTALL README ${P}.lsm spu.html
 }