net-misc/icecast: Fixed openrc init script shebang.
authorLars Wendler <polynomial-c@gentoo.org>
Tue, 3 May 2016 09:30:45 +0000 (11:30 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Tue, 3 May 2016 09:47:30 +0000 (11:47 +0200)
Converted ebuild to EAPI-6.

Package-Manager: portage-2.2.28
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
net-misc/icecast/files/icecast.initd [moved from net-misc/icecast/files/init.d.icecast-2 with 86% similarity]
net-misc/icecast/icecast-2.4.2.ebuild
net-misc/icecast/icecast-2.4.3.ebuild

similarity index 86%
rename from net-misc/icecast/files/init.d.icecast-2
rename to net-misc/icecast/files/icecast.initd
index bde5877c62b63c795be0a35a90793ffddb7fd20c..cb658a3907d476ad52eab29f76591a6e5438f954 100644 (file)
@@ -1,5 +1,5 @@
-#!/sbin/runscript
-# Copyright 1999-2014 Gentoo Foundation
+#!/sbin/openrc-run
+# Copyright 1999-2016 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 extra_started_commands="reload"
index 31271f707df7db2754f8c958a9a2c9b7ae88fb42..225f05f930ddb3986a4789700f5a12ff4def8469 100644 (file)
@@ -58,7 +58,7 @@ src_install() {
        dodoc AUTHORS README TODO HACKING NEWS conf/icecast.xml.dist
        dohtml -A chm,hhc,hhp doc/*
 
-       newinitd "${FILESDIR}"/init.d.icecast-2 icecast
+       newinitd "${FILESDIR}"/${PN}.initd ${PN}
        systemd_dounit "${FILESDIR}"/${PN}.service
 
        insinto /etc/icecast2
index caecb9b2443e66f9a98db3e1ad9283f2829e38b4..e14dda3eb908c98cc7dadafc36529532083bfaa9 100644 (file)
@@ -2,8 +2,8 @@
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
-EAPI=5
-inherit eutils autotools systemd user
+EAPI=6
+inherit autotools systemd user
 
 DESCRIPTION="An opensource alternative to shoutcast that supports mp3, ogg (vorbis/theora) and aac streaming"
 HOMEPAGE="http://www.icecast.org/"
@@ -32,11 +32,16 @@ pkg_setup() {
        enewuser icecast -1 -1 -1 nogroup
 }
 
-src_prepare() {
+PATCHES=(
        # bug #368539
-       epatch "${FILESDIR}"/${PN}-2.3.3-libkate.patch
+       "${FILESDIR}"/${PN}-2.3.3-libkate.patch
        # bug #430434
-       epatch "${FILESDIR}"/${PN}-2.3.3-fix-xiph_openssl.patch
+       "${FILESDIR}"/${PN}-2.3.3-fix-xiph_openssl.patch
+)
+
+src_prepare() {
+       default
+       mv configure.{in,ac} || die
        eautoreconf
 }
 
@@ -56,9 +61,10 @@ src_configure() {
 src_install() {
        emake DESTDIR="${D}" install
        dodoc AUTHORS README TODO HACKING NEWS conf/icecast.xml.dist
-       dohtml -A chm,hhc,hhp doc/*
+       docinto html
+       dodoc doc/*.html
 
-       newinitd "${FILESDIR}"/init.d.icecast-2 icecast
+       newinitd "${FILESDIR}"/${PN}.initd ${PN}
        systemd_dounit "${FILESDIR}"/${PN}.service
 
        insinto /etc/icecast2
@@ -74,7 +80,7 @@ src_install() {
        diropts -m0764 -o icecast -g nogroup
        dodir /var/log/icecast
        keepdir /var/log/icecast
-       rm -rf "${D}"/usr/share/doc/icecast
+       rm -r "${D}"/usr/share/doc/icecast || die
 }
 
 pkg_postinst() {