dev-java/jvmstat: EAPI 6 bump.
authorPatrice Clement <monsieurp@gentoo.org>
Sun, 31 Mar 2019 18:52:58 +0000 (20:52 +0200)
committerPatrice Clement <monsieurp@gentoo.org>
Mon, 1 Apr 2019 08:51:34 +0000 (10:51 +0200)
Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Package-Manager: Portage-2.3.62, Repoman-2.3.11

dev-java/jvmstat/jvmstat-3.0-r1.ebuild [new file with mode: 0644]

diff --git a/dev-java/jvmstat/jvmstat-3.0-r1.ebuild b/dev-java/jvmstat/jvmstat-3.0-r1.ebuild
new file mode 100644 (file)
index 0000000..a8fd913
--- /dev/null
@@ -0,0 +1,59 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit java-pkg-2 versionator
+
+MY_PV=$(replace_version_separator 1 '_')
+
+DESCRIPTION="Monitoring APIs and tools for monitoring the performance of the JVM"
+HOMEPAGE="http://java.sun.com/performance/jvmstat/"
+SRC_URI="jvmstat-${MY_PV}.zip"
+
+LICENSE="sun-bcla-jvmstat"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RESTRICT="fetch strip"
+
+DEPEND="
+       app-arch/unzip
+       >=virtual/jdk-1.5"
+
+RDEPEND="
+       >=virtual/jre-1.5"
+
+S="${WORKDIR}/jvmstat/"
+
+INSTTO="/opt/${PN}"
+
+pkg_nofetch() {
+       einfo "Please go to following URL:"
+       einfo " ${HOMEPAGE}"
+       einfo "download file named ${SRC_URI} and place it into"
+       einfo " your DISTDIR directory."
+}
+
+src_install() {
+       dodir "${INSTTO}"
+       cd "${S}" || die
+       cp -r jars bin "${D}/${INSTTO}" || die
+
+       einstalldocs
+
+       if use doc; then
+               dodoc -r docs
+       fi
+
+       dodir /opt/bin
+       cat > "${D}/opt/bin/visualgc" <<-EOF
+       #!/bin/bash
+       export JVMSTAT_JAVA_HOME=$(java-config -O)
+       cd /opt/jvmstat/bin/
+       ./visualgc \${@}
+       EOF
+       fperms 755 /opt/bin/visualgc
+
+}