dev-perl/BSON: Bump to version 1.10.2 re bug #667328
authorKent Fredric <kentnl@gentoo.org>
Tue, 9 Jul 2019 15:53:42 +0000 (03:53 +1200)
committerKent Fredric <kentnl@gentoo.org>
Tue, 9 Jul 2019 15:55:09 +0000 (03:55 +1200)
Upstream:
- Add support for Extended JSON v2
- Deprecate 'inflate_extjson' method
- Add 'extjson_to_perl' method
- Implement ObjectID spec
- Limit Encoding/Decoding to max depth limits
- BSON::Raw: Add 'get_first_key' method
- Improve BSON error messages

Closes: https://bugs.gentoo.org/667328
Package-Manager: Portage-2.3.66, Repoman-2.3.16
Signed-off-by: Kent Fredric <kentnl@gentoo.org>
dev-perl/BSON/BSON-1.10.2.ebuild [new file with mode: 0644]
dev-perl/BSON/Manifest
dev-perl/BSON/metadata.xml

diff --git a/dev-perl/BSON/BSON-1.10.2.ebuild b/dev-perl/BSON/BSON-1.10.2.ebuild
new file mode 100644 (file)
index 0000000..577ac8e
--- /dev/null
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=MONGODB
+DIST_VERSION=v1.10.2
+inherit perl-module
+
+DESCRIPTION="BSON serialization and deserialization"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+       virtual/perl-Carp
+       dev-perl/Crypt-URandom
+       virtual/perl-Exporter
+       virtual/perl-MIME-Base64
+       virtual/perl-Math-BigInt
+       >=dev-perl/Moo-2.2.4
+       virtual/perl-Scalar-List-Utils
+       dev-perl/Tie-IxHash
+       virtual/perl-Time-HiRes
+       virtual/perl-Time-Local
+       >=dev-perl/boolean-0.450.0
+       virtual/perl-if
+       dev-perl/namespace-clean
+       virtual/perl-threads-shared
+       virtual/perl-version
+"
+DEPEND="${RDEPEND}
+       >=virtual/perl-ExtUtils-MakeMaker-6.170.0
+       test? (
+               >=virtual/perl-CPAN-Meta-2.120.900
+               virtual/perl-Data-Dumper
+               virtual/perl-File-Spec
+               dev-perl/JSON-MaybeXS
+               >=virtual/perl-JSON-PP-2.970.10
+               >=dev-perl/Path-Tiny-0.54.0
+               dev-perl/Test-Deep
+               dev-perl/Test-Fatal
+               >=virtual/perl-Test-Simple-0.960.0
+       )
+"
index 48008ceebf47b70b5922aad73ec359a1bebe7ae2..bce1ef1f4a9d20e85098c0d57a875f65962c56fc 100644 (file)
@@ -1,2 +1,3 @@
+DIST BSON-v1.10.2.tar.gz 116121 BLAKE2B 6fd2d86074303369e584f0ba64b42ce7d811a6eb8cda638e17d74a635c8162baf4bafa9e4724df06857702a0bb8c2ccf756121ebcadf6ff4777c0554f7dde516 SHA512 163dc60966e2eae6c1f130304e2d8eb322ba9f503aaab37e7fb0498262c875ec4b7b24a596361c2333cb495a7c5b465b364310996cb358c5217d58fd74148fbe
 DIST BSON-v1.4.0.tar.gz 99911 BLAKE2B e993b22721f80b444a701dc5017792b54db475abe53e997baba9314b4c30aca0e8f88173d4caa70bbc07fae8131a5f2618bbcba0f3b27b1578b20447c6f3549f SHA512 3904ad3e426514fc826ef3dea31c93c9ce22e3b0d4b4790528e8eba91412e7dc626b44c08a43fb528780bd53a29d25a5b9ad6fd270cfb52fe8e3fdcbc3ba5afe
 DIST BSON-v1.6.7.tar.gz 104454 BLAKE2B 1c72127bcb1dae99bc193c63d4db4eae10cdfb78c03da543b288ea6134a3062dc896da185835c26481636f3b88b2864ac58932c4961cee348bae30a606ee4e1f SHA512 bb3e9f64a09dbdc79cf321cf7807bfb90744bbc2556f0a0c4538fcbbcd8e89e9b79758258306c13da6dc794f8962ec2cb8886f3167775a71ec8d4b69de92b3ee
index d535b9a0609c4fd269a6dc25c949c18e974b45e8..05c84408cc218198ab0d3c83933425cfa026ef6f 100644 (file)
@@ -12,6 +12,7 @@
     <remote-id type="cpan-module">BSON::Bool</remote-id>
     <remote-id type="cpan-module">BSON::Bytes</remote-id>
     <remote-id type="cpan-module">BSON::Code</remote-id>
+    <remote-id type="cpan-module">BSON::DBPointer</remote-id>
     <remote-id type="cpan-module">BSON::DBRef</remote-id>
     <remote-id type="cpan-module">BSON::Decimal128</remote-id>
     <remote-id type="cpan-module">BSON::Doc</remote-id>
@@ -26,6 +27,7 @@
     <remote-id type="cpan-module">BSON::Raw</remote-id>
     <remote-id type="cpan-module">BSON::Regex</remote-id>
     <remote-id type="cpan-module">BSON::String</remote-id>
+    <remote-id type="cpan-module">BSON::Symbol</remote-id>
     <remote-id type="cpan-module">BSON::Time</remote-id>
     <remote-id type="cpan-module">BSON::Timestamp</remote-id>
     <remote-id type="cpan-module">BSON::Types</remote-id>