dev-lang/rust: re-add cblas patch
authorGeorgy Yakovlev <gyakovlev@gentoo.org>
Fri, 1 Feb 2019 04:07:49 +0000 (20:07 -0800)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Fri, 1 Feb 2019 04:36:41 +0000 (20:36 -0800)
Since some systems have stale cblas.h symlink rust's bundled
llvm finds cblas.h and tries to link unconditionally. Fix it.

This reverts commit 0e00cd7cc089acdd3114b4aafc34fc921aabe058.

Closes: https://bugs.gentoo.org/676278
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
dev-lang/rust/files/1.32.0-fix-configure-of-bundled-llvm.patch [new file with mode: 0644]
dev-lang/rust/rust-1.32.0.ebuild

diff --git a/dev-lang/rust/files/1.32.0-fix-configure-of-bundled-llvm.patch b/dev-lang/rust/files/1.32.0-fix-configure-of-bundled-llvm.patch
new file mode 100644 (file)
index 0000000..eaeab87
--- /dev/null
@@ -0,0 +1,32 @@
+Revert "[CMake] Unconditionally add .h and .td files to target sources"
+
+This reverts commit https://github.com/llvm-mirror/llvm/commit/6fb010f388bb2cb2f00fe039123092308ac4865d.
+
+Bug: https://bugs.gentoo.org/675752#c7
+--- a/src/llvm/cmake/modules/LLVMProcessSources.cmake
++++ b/src/llvm/cmake/modules/LLVMProcessSources.cmake
+@@ -52,15 +52,16 @@ function(llvm_process_sources OUT_VAR)
+   cmake_parse_arguments(ARG "" "" "ADDITIONAL_HEADERS;ADDITIONAL_HEADER_DIRS" ${ARGN})
+   set(sources ${ARG_UNPARSED_ARGUMENTS})
+   llvm_check_source_file_list( ${sources} )
+-  
+-  # This adds .td and .h files to the Visual Studio solution:
+-  add_td_sources(sources)
+-  find_all_header_files(hdrs "${ARG_ADDITIONAL_HEADER_DIRS}")
+-  if (hdrs)
+-    set_source_files_properties(${hdrs} PROPERTIES HEADER_FILE_ONLY ON)
++  if( LLVM_ENABLE_IDE )
++    # This adds .td and .h files to the Visual Studio solution:
++    add_td_sources(sources)
++    find_all_header_files(hdrs "${ARG_ADDITIONAL_HEADER_DIRS}")
++    if (hdrs)
++      set_source_files_properties(${hdrs} PROPERTIES HEADER_FILE_ONLY ON)
++    endif()
++    set_source_files_properties(${ARG_ADDITIONAL_HEADERS} PROPERTIES HEADER_FILE_ONLY ON)
++    list(APPEND sources ${ARG_ADDITIONAL_HEADERS} ${hdrs})
+   endif()
+-  set_source_files_properties(${ARG_ADDITIONAL_HEADERS} PROPERTIES HEADER_FILE_ONLY ON)
+-  list(APPEND sources ${ARG_ADDITIONAL_HEADERS} ${hdrs})
+   set( ${OUT_VAR} ${sources} PARENT_SCOPE )
+ endfunction(llvm_process_sources)
index ea00024950f2b88cdfd8eeedcbb4f75f6e188639..bc2a6106b8ade78ca032dddc7bc42222b13d7840 100644 (file)
@@ -63,6 +63,7 @@ S="${WORKDIR}/${MY_P}-src"
 
 PATCHES=(
        "${FILESDIR}"/1.30.1-clippy-sysroot.patch
+       "${FILESDIR}"/1.32.0-fix-configure-of-bundled-llvm.patch
        "${FILESDIR}"/1.32.0-system-llvm-7-SIGSEGV.patch
 )