dev-python/kiwisolver: Bump to version 1.2.0
authorVictor Payno <vpayno+gentoo@gmail.com>
Mon, 13 Apr 2020 22:22:25 +0000 (15:22 -0700)
committerPatrick McLean <chutzpah@gentoo.org>
Sun, 26 Apr 2020 03:11:48 +0000 (20:11 -0700)
Signed-off-by: Victor Payno <vpayno+gentoo@gmail.com>
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
dev-python/kiwisolver/Manifest
dev-python/kiwisolver/kiwisolver-1.2.0.ebuild [new file with mode: 0644]
dev-python/kiwisolver/metadata.xml

index 692a7a275b87d995a21da477d54b9a08a5261c0b..5b1c2660a12fb633530ffb13039bbd8a42e52594 100644 (file)
@@ -1,2 +1,3 @@
 DIST kiwisolver-1.0.1.tar.gz 34783 BLAKE2B 104fb7789e004841921bc43fe98a98b247c7f0506a94b07d10ff1e758287a272c9d2f119b7a086847653cdf1bfc9d5c94823d1eb0b4a30ea93cf2b8b05027013 SHA512 01002ae1dbf6482ed68c49ad3da80b772db84ec221c4b111c42f1b493f19299e0ddb187e43e64b380eb2ddc292d5848d6e09a5a1dbfaf68950a65423a913ec18
 DIST kiwisolver-1.1.0.tar.gz 55086 BLAKE2B 5f45a9c540a1a732cf8319de7dc2e6b503170cd40eac4287815c0c45f4f88a05c384e57a24ffb6edefde949718a09a35de87478c00a2a63643fc1294e548ba37 SHA512 e26a951fdba2fb221effe7ed785010d5795695b30e19fb67a30dc2ac883ee21b1daec967ad89734309c101513cd17bb5971118591270f402b8d46098178aff25
+DIST kiwisolver-1.2.0.tar.gz 54244 BLAKE2B 42590c2cbb78b3c2ed568373616e772326bf5a0e133396d9e9cf6468132ec88b45d40f68f51baff7bc22ca261567ebab81cf2585009657bd2a59df4e97c33f1f SHA512 05541ff46cc64b9958d714452138dc7bb343e6cc9308408a3f8cf25242e9640af37f8bfd22a7038e8ca70a895f57bdb983346259bce22b1630ac10b974d00a0e
diff --git a/dev-python/kiwisolver/kiwisolver-1.2.0.ebuild b/dev-python/kiwisolver/kiwisolver-1.2.0.ebuild
new file mode 100644 (file)
index 0000000..fd71991
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="An efficient C++ implementation of the Cassowary constraint solving algorithm"
+HOMEPAGE="https://github.com/nucleic/kiwi"
+SRC_URI="https://github.com/nucleic/kiwi/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Clear-BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+       >=dev-python/cppy-1.1.0[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/kiwi-${PV}
+
+distutils_enable_tests pytest
index 6ee72f23530283b8fabba667b44fcc7a1cb3cae5..4b4e945d15915c7b2eaefcae088981c4798edab6 100644 (file)
@@ -1,9 +1,16 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
-<!-- maintainer-needed -->
-  <upstream>
-    <remote-id type="pypi">kiwisolver</remote-id>
-    <remote-id type="github">nucleic/kiwi</remote-id>
-  </upstream>
+       <maintainer type="person">
+               <email>vpayno+gentoo@gmail.com</email>
+               <name>Victor Payno</name>
+       </maintainer>
+       <maintainer type="person">
+               <email>gyakovlev@gentoo.org</email>
+               <name>Georgy Yakovlev</name>
+       </maintainer>
+       <upstream>
+               <remote-id type="pypi">kiwisolver</remote-id>
+               <remote-id type="github">nucleic/kiwi</remote-id>
+       </upstream>
 </pkgmetadata>