games-util/qjoypad: Fix CXXFLAGS, EAPI-7 bump
authorAndreas Sturmlechner <asturm@gentoo.org>
Fri, 8 Nov 2019 20:41:04 +0000 (21:41 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Fri, 8 Nov 2019 20:41:13 +0000 (21:41 +0100)
Closes: https://bugs.gentoo.org/699636
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
games-util/qjoypad/files/qjoypad-4.3.0-cmake.patch [new file with mode: 0644]
games-util/qjoypad/qjoypad-4.3.0.ebuild

diff --git a/games-util/qjoypad/files/qjoypad-4.3.0-cmake.patch b/games-util/qjoypad/files/qjoypad-4.3.0-cmake.patch
new file mode 100644 (file)
index 0000000..da2ce50
--- /dev/null
@@ -0,0 +1,14 @@
+--- a/CMakeLists.txt   2016-04-03 01:17:15.000000000 +0200
++++ b/CMakeLists.txt   2019-11-08 21:38:16.713130838 +0100
+@@ -39,11 +39,6 @@
+       add_definitions(-DPLAIN_KEYS)
+ endif()
+-if(CMAKE_COMPILER_IS_GNUCC OR CMAKE_COMPILER_IS_GNUCXX)
+-      set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Wextra -Werror -pedantic -Wno-variadic-macros")
+-      set(CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS_RELEASE} -O3")
+-endif()
+-
+ set(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} -D_DEBUG")
+ # for config.h
index a1572020293d70da96abb53236e3de1f27750f7f..71d99ae8ad0cec8ef40249d1bf3231439ab9af0a 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
 inherit cmake-utils desktop
 
@@ -14,6 +14,9 @@ SLOT="0"
 KEYWORDS="~amd64 ~x86"
 IUSE=""
 
+BDEPEND="
+       dev-qt/linguist-tools:5
+"
 RDEPEND="
        dev-qt/qtcore:5
        dev-qt/qtgui:5
@@ -24,10 +27,11 @@ RDEPEND="
        x11-libs/libXtst
 "
 DEPEND="${RDEPEND}
-       dev-qt/linguist-tools:5
        x11-base/xorg-proto
 "
 
+PATCHES=( "${FILESDIR}/${P}-cmake.patch" )
+
 src_install() {
        cmake-utils_src_install