Removed sed-4 from *DEPEND.
authorChris Gianelloni <wolf31o2@gentoo.org>
Wed, 6 Dec 2006 17:09:46 +0000 (17:09 +0000)
committerChris Gianelloni <wolf31o2@gentoo.org>
Wed, 6 Dec 2006 17:09:46 +0000 (17:09 +0000)
Package-Manager: portage-2.1.2_rc2-r2

12 files changed:
games-arcade/cavezofphear/ChangeLog
games-arcade/cavezofphear/cavezofphear-0.1.ebuild
games-arcade/insaneodyssey/ChangeLog
games-arcade/insaneodyssey/insaneodyssey-000311.ebuild
games-arcade/kajaani-kombat/ChangeLog
games-arcade/kajaani-kombat/kajaani-kombat-0.6.6.6.ebuild
games-arcade/missile/ChangeLog
games-arcade/missile/missile-1.0.1.ebuild
games-arcade/rockdodger/ChangeLog
games-arcade/rockdodger/rockdodger-0.6.0a-r1.ebuild
games-arcade/sdlroids/ChangeLog
games-arcade/sdlroids/sdlroids-1.3.4-r3.ebuild

index d02ca71fced429e9298c6b248ab9f14022fc8c2f..d56dc2e87e2de2a659beeeb83f042dd35ce963b7 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for games-arcade/cavezofphear
 # Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/cavezofphear/ChangeLog,v 1.6 2006/10/05 21:19:16 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/cavezofphear/ChangeLog,v 1.7 2006/12/06 17:01:11 wolf31o2 Exp $
+
+  06 Dec 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+  cavezofphear-0.1.ebuild:
+  Removed sed-4 from *DEPEND.
 
   05 Oct 2006; Daniel Gryniewicz <dang@gentoo.org> cavezofphear-0.1.ebuild:
   Marked stable on amd64 for bug #150189
index ed09a8eb56d5acc17d9fb3dc7cdcb3ad6f409224..b602d42fcebfc89913453ab6a63ad551cb0106d2 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/cavezofphear/cavezofphear-0.1.ebuild,v 1.9 2006/10/05 21:19:15 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/cavezofphear/cavezofphear-0.1.ebuild,v 1.10 2006/12/06 17:01:11 wolf31o2 Exp $
 
 inherit games
 
@@ -14,14 +14,12 @@ KEYWORDS="amd64 ppc ppc64 ~sparc x86"
 IUSE=""
 
 RDEPEND="sys-libs/ncurses"
-DEPEND="${RDEPEND}
-       >=sys-apps/sed-4"
 
-S="${WORKDIR}/${P/cavezof/}"
+S=${WORKDIR}/${P/cavezof/}
 
 src_unpack() {
        unpack ${A}
-       cd ${S}
+       cd "${S}"
 
        sed -i \
                -e 's/cd src.*/$(MAKE) -C src/' Makefile \
@@ -43,8 +41,8 @@ src_unpack() {
 src_install() {
        dogamesbin src/phear || die "dogamesbin failed"
        newgamesbin src/editor phear-editor || die "newgamesbin failed"
-       dodir ${GAMES_DATADIR}/${PN}
-       cp -r data/ ${D}/${GAMES_DATADIR}/${PN} || die "cp failed"
+       dodir "${GAMES_DATADIR}"/${PN}
+       cp -r data/ ${D}/"${GAMES_DATADIR}"/${PN} || die "cp failed"
        dodoc AUTHORS ChangeLog README* TODO
        prepgamesdirs
 }
index e3b1be9d8fb7de35f53427f49638088f2270e3f4..db639b7a3777e58b4b8bebca14398fe33fc1e19c 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for games-arcade/insaneodyssey
 # Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/insaneodyssey/ChangeLog,v 1.4 2006/03/07 20:36:13 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/insaneodyssey/ChangeLog,v 1.5 2006/12/06 17:02:08 wolf31o2 Exp $
+
+  06 Dec 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+  insaneodyssey-000311.ebuild:
+  Removed sed-4 from *DEPEND.
 
   07 Mar 2006; <Tupone@gentoo.org>
   files/insaneodyssey-000311-datafiles.patch:
index bcb75bbf16ebca93f23894a3cd06145596c09139..b87a1666887344ddc5eb27e888e833847d7ef194 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/insaneodyssey/insaneodyssey-000311.ebuild,v 1.4 2004/08/03 11:50:43 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/insaneodyssey/insaneodyssey-000311.ebuild,v 1.5 2006/12/06 17:02:08 wolf31o2 Exp $
 
 inherit eutils games
 
@@ -19,12 +19,9 @@ RDEPEND=">=media-libs/libsdl-1.2.7
        >=media-libs/sdl-mixer-1.2.5
        >=media-libs/sdl-image-1.2.3"
 
-DEPEND="${RDEPEND}
-       >=sys-apps/sed-4"
+S=${WORKDIR}/${PN}
 
-S="${WORKDIR}/${PN}"
-
-DEST_DIR="${GAMES_DATADIR}/${PN}"
+DEST_DIR=${GAMES_DATADIR}/${PN}
 
 src_unpack() {
        unpack ${A}
index 221cb7e97d269a4376027e4981e6a68d7af53b18..e5fbb9a3e7549475f01063a4976e7a98daa55f2c 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for games-arcade/kajaani-kombat
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/kajaani-kombat/ChangeLog,v 1.7 2005/11/22 07:47:34 mr_bones_ Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/kajaani-kombat/ChangeLog,v 1.8 2006/12/06 17:03:35 wolf31o2 Exp $
+
+  06 Dec 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+  kajaani-kombat-0.6.6.6.ebuild:
+  Removed sed-4 from *DEPEND.
 
 *kajaani-kombat-0.7 (22 Nov 2005)
 
index 0241155c2bc1a13d5bebaf3a2a9834718e833465..b521bd7fc49987d30e6fbbbac2569135a2af60f5 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/kajaani-kombat/kajaani-kombat-0.6.6.6.ebuild,v 1.1 2005/03/01 06:12:30 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/kajaani-kombat/kajaani-kombat-0.6.6.6.ebuild,v 1.2 2006/12/06 17:03:35 wolf31o2 Exp $
 
 inherit eutils games
 
@@ -19,8 +19,6 @@ RDEPEND="media-libs/libsdl
        media-libs/sdl-ttf
        sys-libs/ncurses
        sys-libs/readline"
-DEPEND="${RDEPEND}
-       >=sys-apps/sed-4"
 
 src_unpack() {
        unpack ${A}
index 258a28e75c8a2d969507b18cdb99c9c1c0ef9190..5373ab6ff75e2e32e96852cb9190f2512505ad5f 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for games-arcade/missile
 # Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/missile/ChangeLog,v 1.10 2006/05/11 22:33:46 tcort Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/missile/ChangeLog,v 1.11 2006/12/06 17:04:44 wolf31o2 Exp $
+
+  06 Dec 2006; Chris Gianelloni <wolf31o2@gentoo.org> missile-1.0.1.ebuild:
+  Removed sed-4 from *DEPEND.
 
   11 May 2006; Thomas Cort <tcort@gentoo.org> missile-1.0.1.ebuild:
   Stable on alpha.
index 1122ab91cdcc753d6f7a340497eb3ccd5b33fbfc..cfa3eca76c2d0b137ee4ed4a036fb43410f2c756 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/missile/missile-1.0.1.ebuild,v 1.12 2006/05/11 22:33:46 tcort Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/missile/missile-1.0.1.ebuild,v 1.13 2006/12/06 17:04:44 wolf31o2 Exp $
 
 inherit eutils games
 
@@ -17,8 +17,6 @@ RDEPEND=">=media-libs/libsdl-1.2.4
        >=media-libs/sdl-image-1.2.1
        >=media-libs/sdl-mixer-1.2.4
        media-libs/libpng"
-DEPEND="${RDEPEND}
-       >=sys-apps/sed-4"
 
 src_unpack() {
        unpack ${A}
index 78710357bebf476722c7ec3b7272fecf8ae1f6a6..1c9368d576df50afb0cc1fe9b65831bf338647b2 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for games-arcade/rockdodger
 # Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/rockdodger/ChangeLog,v 1.7 2006/09/20 16:49:12 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/rockdodger/ChangeLog,v 1.8 2006/12/06 17:06:04 wolf31o2 Exp $
+
+  06 Dec 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+  rockdodger-0.6.0a-r1.ebuild:
+  Removed sed-4 from *DEPEND.
 
   20 Sep 2006; <blubb@gentoo.org> rockdodger-0.6.0a-r1.ebuild:
   stable on amd64
index 2130d86ea880ef2796b409c3c1b9076feb65f8f8..0c1e15c1fd647c57905bcb740d84df6ccf8459d2 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/rockdodger/rockdodger-0.6.0a-r1.ebuild,v 1.4 2006/09/20 16:49:12 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/rockdodger/rockdodger-0.6.0a-r1.ebuild,v 1.5 2006/12/06 17:06:04 wolf31o2 Exp $
 
 inherit eutils games
 
@@ -17,11 +17,9 @@ RDEPEND=">=media-libs/libsdl-1.2.2
        >=media-libs/sdl-image-1.2
        >=media-libs/sdl-mixer-1.2"
 
-DEPEND="${RDEPEND}
-       >=sys-apps/sed-4"
+GAME_DEST_DIR=${GAMES_DATADIR}/${PN}
 
 src_unpack() {
-       GAME_DEST_DIR="${GAMES_DATADIR}/${PN}"
        unpack ${A}
        cd "${S}"
 
index 476a4acc8971d2ca3cdc3ddf1826f0b2518f77c6..b10f6b78ea20dc3ee051a92e8394e8f87bab0459 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for games-arcade/sdlroids
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/sdlroids/ChangeLog,v 1.10 2005/09/11 02:54:35 agriffis Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/sdlroids/ChangeLog,v 1.11 2006/12/06 17:09:46 wolf31o2 Exp $
+
+  06 Dec 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+  sdlroids-1.3.4-r3.ebuild:
+  Removed sed-4 from *DEPEND.
 
   10 Sep 2005; Aron Griffis <agriffis@gentoo.org> sdlroids-1.3.4-r3.ebuild:
   Mark 1.3.4-r3 stable on alpha
index 9856951302c1c017bcb4d8150809fe82427413cb..8fbdfef0301cc77902d8adebbaf7f9dddca8107b 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/sdlroids/sdlroids-1.3.4-r3.ebuild,v 1.8 2005/09/11 02:54:35 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/sdlroids/sdlroids-1.3.4-r3.ebuild,v 1.9 2006/12/06 17:09:46 wolf31o2 Exp $
 
 inherit eutils games
 
@@ -15,8 +15,6 @@ IUSE=""
 
 RDEPEND=">=media-libs/libsdl-1.1.8
        media-libs/sdl-mixer"
-DEPEND="${RDEPEND}
-       >=sys-apps/sed-4"
 
 src_unpack() {
        unpack ${A}