sys-cluster/neutron: clean up pkgcheck issues
authorMatthew Thode <prometheanfire@gentoo.org>
Fri, 24 Jan 2020 21:17:35 +0000 (15:17 -0600)
committerMatthew Thode <prometheanfire@gentoo.org>
Fri, 24 Jan 2020 21:17:52 +0000 (15:17 -0600)
Closes: https://bugs.gentoo.org/705828
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
sys-cluster/neutron/neutron-2019.2.9999.ebuild

index ba485cb5c83111d70550ac2bd71cb8027daf7643..518d9465fd1a854d54912e0e1b05e3b607d337cb 100644 (file)
@@ -5,7 +5,7 @@ EAPI=7
 PYTHON_COMPAT=( python3_{6,7} )
 # still no 34 :( https://bugs.launchpad.net/neutron/+bug/1630439
 
-inherit distutils-r1 linux-info user
+inherit distutils-r1 linux-info
 
 DESCRIPTION="A virtual network service for Openstack"
 HOMEPAGE="https://launchpad.net/neutron"
@@ -118,7 +118,9 @@ RDEPEND="
                net-misc/radvd
                >=net-misc/dibbler-1.0.1
        )
-       dhcp? ( net-dns/dnsmasq[dhcp-tools] )"
+       dhcp? ( net-dns/dnsmasq[dhcp-tools] )
+       acct-group/neutron
+       acct-user/neutron"
 
 #PATCHES=(
 #)
@@ -135,11 +137,6 @@ pkg_pretend() {
        fi
 }
 
-pkg_setup() {
-       enewgroup neutron
-       enewuser neutron -1 -1 /var/lib/neutron neutron
-}
-
 pkg_config() {
        fperms 0700 /var/log/neutron
        fowners neutron:neutron /var/log neutron
@@ -157,7 +154,7 @@ python_install_all() {
        if use server; then
                newinitd "${FILESDIR}/neutron.initd" "neutron-server"
                newconfd "${FILESDIR}/neutron-server.confd" "neutron-server"
-               dosym /etc/neutron/plugin.ini /etc/neutron/plugins/ml2/ml2_conf.ini
+               dosym ../../plugin.ini /etc/neutron/plugins/ml2/ml2_conf.ini
        fi
        if use dhcp; then
                newinitd "${FILESDIR}/neutron.initd" "neutron-dhcp-agent"