acct-user/spectrum: add user for net-im/spectrum2
authorConrad Kostecki <conrad@kostecki.com>
Tue, 17 Sep 2019 17:59:05 +0000 (19:59 +0200)
committerAndrey Utkin <andrey_utkin@gentoo.org>
Fri, 20 Sep 2019 08:46:27 +0000 (09:46 +0100)
UID 486 will be used, as its the next available.
Arch, Fedora and RHEL don't have a UID for the user.

Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Conrad Kostecki <conrad@kostecki.com>
Signed-off-by: Andrey Utkin <andrey_utkin@gentoo.org>
acct-user/spectrum/metadata.xml [new file with mode: 0644]
acct-user/spectrum/spectrum-0.ebuild [new file with mode: 0644]

diff --git a/acct-user/spectrum/metadata.xml b/acct-user/spectrum/metadata.xml
new file mode 100644 (file)
index 0000000..54d5423
--- /dev/null
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>ck+gentoo@bl4ckb0x.de</email>
+               <name>Conrad Kostecki</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>proxy-maint@gentoo.org</email>
+               <name>Proxy Maintainers</name>
+       </maintainer>
+</pkgmetadata>
diff --git a/acct-user/spectrum/spectrum-0.ebuild b/acct-user/spectrum/spectrum-0.ebuild
new file mode 100644 (file)
index 0000000..47560fb
--- /dev/null
@@ -0,0 +1,14 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit acct-user
+
+DESCRIPTION="A user for the Spectrum messaging transport"
+
+ACCT_USER_GROUPS=( "spectrum" )
+ACCT_USER_HOME="/var/lib/spectrum2"
+ACCT_USER_ID="486"
+
+acct-user_add_deps