app-crypt/elettra: bump EAPI and stuff
authorAaron Bauman <bman@gentoo.org>
Sun, 10 Nov 2019 03:57:18 +0000 (22:57 -0500)
committerAaron Bauman <bman@gentoo.org>
Sun, 10 Nov 2019 03:57:18 +0000 (22:57 -0500)
Signed-off-by: Aaron Bauman <bman@gentoo.org>
app-crypt/elettra/elettra-1.0.ebuild

index 4e47c0f1db086a3a8318bef245e5c91df4d628ac..c15d05715817be43f5f50182b5e1330d30715c5e 100644 (file)
@@ -1,15 +1,15 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
+EAPI=7
 
 inherit toolchain-funcs
 
 MY_P="${PN}-src-${PV}"
 
 DESCRIPTION="Plausible deniable file cryptography"
-HOMEPAGE="http://www.winstonsmith.info/julia/elettra/"
-SRC_URI="http://www.winstonsmith.info/julia/elettra/${MY_P}.tar.gz"
+HOMEPAGE="https://www.winstonsmith.info/julia/elettra/"
+SRC_URI="https://www.winstonsmith.info/julia/elettra/${MY_P}.tar.gz"
 
 LICENSE="WTFPL-2"
 SLOT="0"
@@ -17,8 +17,8 @@ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
 IUSE=""
 
 RDEPEND="sys-libs/zlib
-                app-crypt/mhash
-                dev-libs/libmcrypt"
+       app-crypt/mhash
+       dev-libs/libmcrypt"
 
 DEPEND="${RDEPEND}"
 
@@ -31,6 +31,6 @@ src_compile() {
 }
 
 src_install() {
-       dobin elettra || die "dobin failed"
-       dodoc README || die "dodoc failed"
+       dobin elettra
+       dodoc README
 }