net-dns/rbldnsd: fix CC detection at configure time.
authorMichael Orlitzky <mjo@gentoo.org>
Wed, 22 Apr 2020 17:49:12 +0000 (13:49 -0400)
committerMichael Orlitzky <mjo@gentoo.org>
Wed, 22 Apr 2020 17:49:12 +0000 (13:49 -0400)
The build system for rbldnsd is hand-written. While we were already
passing CC to the "emake" command, it turns out that the ./configure
script checks for it as well. Thus it was possible for src_configure()
to fail if the ./configure script couldn't guess which compiler
wouldn't be used anyway. Whee. Fixed by passing the same CC that emake
will use to ./configure, too.

Closes: https://bugs.gentoo.org/718888
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
net-dns/rbldnsd/rbldnsd-0.998b-r2.ebuild

index a95bcde36f78549be0f56862394bb12ab30c72a7..fb38ede3d4c6686932451909055fbe0707a3f086 100644 (file)
@@ -28,8 +28,10 @@ RESTRICT=test
 src_configure() {
        # The ./configure file is handwritten and doesn't support a `make
        # install` target, so there are no --prefix options. The econf
-       # function appends those automatically, so we can't use it.
-       ./configure \
+       # function appends those automatically, so we can't use it. We
+       # Have to set $CC here, too (and not just in the call to emake),
+       # because the ./configure script checks for it.
+       CC="$(tc-getCC)" ./configure \
                $(use_enable ipv6) \
                $(use_enable zlib) \
                || die "./configure failed"