sci-calculators/bc-gh: new package
authorGavin Howard <yzena.tech@gmail.com>
Tue, 26 Nov 2019 15:00:11 +0000 (08:00 -0700)
committerJoonas Niilola <juippis@gentoo.org>
Thu, 28 Nov 2019 16:34:26 +0000 (18:34 +0200)
An implementation of dc and POSIX bc with GNU extensions meant to be as
bug-free and fast as possible.

Signed-off-by: Gavin Howard <yzena.tech@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/11716
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
sci-calculators/bc-gh/Manifest [new file with mode: 0644]
sci-calculators/bc-gh/bc-gh-2.3.2.ebuild [new file with mode: 0644]
sci-calculators/bc-gh/metadata.xml [new file with mode: 0644]

diff --git a/sci-calculators/bc-gh/Manifest b/sci-calculators/bc-gh/Manifest
new file mode 100644 (file)
index 0000000..3930fb1
--- /dev/null
@@ -0,0 +1 @@
+DIST bc-2.3.2.tar.xz 160120 BLAKE2B b9919d45cb45b69c7b10022d472c480fd6e93ffdf65eda1a0ee3e3990e2ad79fced74e5b72276559c6265fd43d08af28d5590c0e3a7bb14fd294010b8bc7b772 SHA512 732cf67a27b537406418ddb1a11c1da0fcbda23bdb7beba0e16a57a9d6639cdb7b9b43f5028c8fac45fe253dadfcb80b50d7fef0bbe32a7391cd946ace1408f8
diff --git a/sci-calculators/bc-gh/bc-gh-2.3.2.ebuild b/sci-calculators/bc-gh/bc-gh-2.3.2.ebuild
new file mode 100644 (file)
index 0000000..ff0f2ac
--- /dev/null
@@ -0,0 +1,19 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Implementation of POSIX bc with GNU extensions"
+HOMEPAGE="https://github.com/gavinhoward/bc"
+SRC_URI="https://github.com/gavinhoward/bc/releases/download/${PV}/bc-${PV}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/bc-${PV}"
+
+src_configure() {
+       EXECSUFFIX="-gh" PREFIX="${EPREFIX}/usr" ./configure.sh -GT || die
+}
diff --git a/sci-calculators/bc-gh/metadata.xml b/sci-calculators/bc-gh/metadata.xml
new file mode 100644 (file)
index 0000000..1f88059
--- /dev/null
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <name>Gavin D. Howard</name>
+               <email>yzena.tech@gmail.com</email>
+       </maintainer>
+       <maintainer type="project">
+               <email>proxy-maint@gentoo.org</email>
+               <name>Proxy Maintainers</name>
+       </maintainer>
+       <upstream>
+               <maintainer>
+                       <name>Gavin D. Howard</name>
+                       <email>yzena.tech@gmail.com</email>
+               </maintainer>
+               <bugs-to>https://github.com/gavinhoward/bc</bugs-to>
+               <doc>https://github.com/gavinhoward/bc/tree/master/manuals</doc>
+       </upstream>
+       <longdescription lang="en">
+       An implementation of POSIX bc and Unix dc with GNU extensions and some of
+       their own extensions. It also removes the dangerous '!' dc command.
+       This bc/dc is especially useful for programmers, with extra math and a
+       larger builtin library with some hardware-oriented print functions.
+       </longdescription>
+</pkgmetadata>