app-text/blogc: updated live ebuild, added new use flags.
authorRafael Martins <rafaelmartins@gentoo.org>
Thu, 28 Apr 2016 02:03:11 +0000 (04:03 +0200)
committerRafael Martins <rafaelmartins@gentoo.org>
Thu, 28 Apr 2016 02:03:25 +0000 (04:03 +0200)
Package-Manager: portage-2.2.26

app-text/blogc/blogc-9999.ebuild
app-text/blogc/metadata.xml

index 4a8d832ace1eb02cc49ece38d24a7891cebfd345..6c8b9ca45f17689194921e1bbf03f90ca11a5b76 100644 (file)
@@ -12,32 +12,37 @@ if [[ ${PV} = *9999* ]]; then
 fi
 
 DESCRIPTION="A blog compiler"
-HOMEPAGE="http://blogc.org/"
+HOMEPAGE="https://blogc.rgm.io/"
 
 SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
 KEYWORDS="~amd64 ~x86"
 if [[ ${PV} = *9999* ]]; then
        SRC_URI=""
        KEYWORDS=""
-       RDEPEND="=dev-libs/squareball-9999"
-       DEPEND="${RDEPEND}
-               app-text/ronn"
-else
-       RDEPEND=">=dev-libs/squareball-0.2.0"
-       DEPEND="${RDEPEND}"
+       DEPEND="app-text/ronn"
 fi
 
 LICENSE="BSD"
 SLOT="0"
-IUSE="test"
+IUSE="git httpd test"
+
+CDEPEND="
+       httpd? (
+               dev-libs/libevent
+               sys-apps/file )"
+
+RDEPEND="${CDEPEND}
+       git? (
+               dev-vcs/git )"
 
 DEPEND="${DEPEND}
+       ${CDEPEND}
        virtual/pkgconfig
        test? (
                dev-util/cmocka )"
 
 src_prepare() {
-       [[ ${PV} = *9999* ]] && AT_NO_RECURSIVE=1 eautoreconf
+       [[ ${PV} = *9999* ]] && eautoreconf
        eapply_user
        default
 }
@@ -51,7 +56,8 @@ src_configure() {
        fi
        econf \
                $(use_enable test tests) \
+               $(use_enable git git-receiver) \
+               $(use_enable httpd runserver) \
                --disable-valgrind \
-               --with-squareball=system \
                ${myconf}
 }
index ad0a08828cb217503406b63ee0bee231f7c9c784..e5a1537294f7ce97bcea8994374e883cbc5a1500 100644 (file)
@@ -16,4 +16,8 @@
                </maintainer>
                <remote-id type="github">blogc/blogc</remote-id>
        </upstream>
+       <use>
+               <flag name="git">Build blogc-git-receiver tool</flag>
+               <flag name="httpd">Build blogc-runserver tool</flag>
+       </use>
 </pkgmetadata>