dev-libs/ilbc-rfc3951: add blocker against media-libs/libilbc.
authorJaco Kroon <jaco@uls.co.za>
Sun, 3 May 2020 13:33:31 +0000 (15:33 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Tue, 12 May 2020 13:57:07 +0000 (16:57 +0300)
media-libs/libilbc seems to be a drop-in replacement for
dev-libs/ilbc-rfc3951.

I intend to retire ilbc-rfc3951 as I've already switched asterisk to
media-libs/libilbc.

Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Jaco Kroon <jaco@uls.co.za>
Closes: https://github.com/gentoo/gentoo/pull/15624
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
dev-libs/ilbc-rfc3951/ilbc-rfc3951-0-r2.ebuild [new file with mode: 0644]

diff --git a/dev-libs/ilbc-rfc3951/ilbc-rfc3951-0-r2.ebuild b/dev-libs/ilbc-rfc3951/ilbc-rfc3951-0-r2.ebuild
new file mode 100644 (file)
index 0000000..e0e5d1c
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="iLBC is a speech codec suitable for robust voice communication over IP"
+HOMEPAGE="https://webrtc.org/license/ilbc-freeware/"
+SRC_URI="http://simon.morlat.free.fr/download/1.1.x/source/ilbc-rfc3951.tar.gz -> ${P}.tar.gz"
+
+# relicensed under 3-clause BSD license, bug 390797
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+S="${WORKDIR}/${PN}"
+PATCHES=( "${FILESDIR}"/${PN}-asneeded.patch )
+
+RDEPEND="!media-libs/libilbc"
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+src_configure() {
+       econf \
+               --enable-shared \
+               --disable-static
+}
+
+src_install() {
+       default
+       find "${D}" -name '*.la' -delete || die
+}