dev-python/paste: Set DISTUTILS_USE_SETUPTOOLS
authorMichał Górny <mgorny@gentoo.org>
Mon, 27 Jan 2020 06:41:35 +0000 (07:41 +0100)
committerMichał Górny <mgorny@gentoo.org>
Mon, 27 Jan 2020 07:22:13 +0000 (08:22 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/paste/paste-3.2.3.ebuild

index d0d437d3a61e6f949fd1b41b896b809f2c232e52..eb9f07e5598bba98f61f0f52620af19c71ee5e89 100644 (file)
@@ -2,6 +2,8 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
 PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
 
 inherit distutils-r1
@@ -22,8 +24,7 @@ RDEPEND="dev-python/namespace-paste[${PYTHON_USEDEP}]
        >=dev-python/six-1.4.0[${PYTHON_USEDEP}]
        flup? ( dev-python/flup[$(python_gen_usedep 'python2*')] )
        openid? ( dev-python/python-openid[$(python_gen_usedep 'python2*')] )"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
 
 S="${WORKDIR}/${MY_P}"