net-libs/aqbanking: fix deletion of doc dir
authorHanno <hanno@gentoo.org>
Sat, 25 Jun 2016 18:14:44 +0000 (20:14 +0200)
committerHanno <hanno@gentoo.org>
Sat, 25 Jun 2016 18:14:44 +0000 (20:14 +0200)
This fixes bug #582842 and also does not try to build
the obsolete paypal backend.

Package-Manager: portage-2.3.0

net-libs/aqbanking/aqbanking-5.6.10.ebuild

index f84bad5480fccea008d2dc0301fb646b124c4809..b7acebf6611adf42920999070fc4f0136258b8c7 100644 (file)
@@ -31,7 +31,7 @@ DEPEND="${RDEPEND}
 MAKEOPTS="${MAKEOPTS} -j1" # 5.0.x fails with -j9 on quadcore
 
 src_configure() {
-       local backends="aqhbci aqnone aqpaypal"
+       local backends="aqhbci aqnone"
        use ofx && backends="${backends} aqofxconnect"
        use ebics && backends="${backends} aqebics"
 
@@ -49,7 +49,7 @@ src_configure() {
 src_install() {
        emake DESTDIR="${D}" install
 
-       rm -rv "${ED}"/usr/share/doc/aq{banking,hbci,paypal} || die
+       rm -rv "${ED}"/usr/share/doc/ || die
 
        dodoc AUTHORS ChangeLog NEWS README TODO