use games_get_libdir
authorTristan Heaven <tristan@gentoo.org>
Mon, 9 Apr 2007 20:54:11 +0000 (20:54 +0000)
committerTristan Heaven <tristan@gentoo.org>
Mon, 9 Apr 2007 20:54:11 +0000 (20:54 +0000)
Package-Manager: portage-2.1.2.3

games-rpg/openrpg/openrpg-1.6.1-r1.ebuild
games-rpg/xu4/xu4-0.9.ebuild

index 2f9bc7b0c1c8c39f036a34780f0ba34cfc56281c..1acb2a1b39d95be6b265c6f1ae69cecf130bab26 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2004 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/openrpg/openrpg-1.6.1-r1.ebuild,v 1.2 2004/12/14 22:26:00 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/openrpg/openrpg-1.6.1-r1.ebuild,v 1.3 2007/04/09 20:51:48 nyhm Exp $
 
 inherit eutils games
 
@@ -34,7 +34,7 @@ src_unpack() {
        rm -f start.py start_server.py start_server_gui.py
        sed -i \
                -e "s:GENTOO_DATADIR:${GAMES_DATADIR}/${PN}:" \
-               -e "s:GENTOO_LIBDIR:${GAMES_LIBDIR}/${PN}:" \
+               -e "s:GENTOO_LIBDIR:$(games_get_libdir)/${PN}:" \
                "${WORKDIR}/bins/openrpg" \
                "${WORKDIR}/bins/openrpg-server" \
                "${WORKDIR}/bins/openrpg-server-gui" \
@@ -46,9 +46,9 @@ src_install() {
        dogamesbin "${WORKDIR}/bins/"*
        dodoc "${WORKDIR}/docs/"*
 
-       insinto "${GAMES_LIBDIR}/${PN}"
+       insinto "$(games_get_libdir)/${PN}"
        doins *.py || die "doins failed"
-       cp -r orpg "${D}/${GAMES_LIBDIR}/${PN}/" || die "cp failed"
+       cp -r orpg "${D}/$(games_get_libdir)/${PN}/" || die "cp failed"
 
        dodir "${GAMES_DATADIR}/${PN}/orpg"
        cp -r templates/ "${D}/${GAMES_DATADIR}/${PN}/orpg/" || die "cp failed"
index cee72813de8d6ca7fe9fb147646a81d220344759..061539a91777b44a2fdfcf8aa92afee5da1c6e19 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/xu4/xu4-0.9.ebuild,v 1.5 2006/12/21 23:29:29 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/xu4/xu4-0.9.ebuild,v 1.6 2007/04/09 20:54:11 nyhm Exp $
 
 inherit eutils games
 
@@ -17,12 +17,11 @@ IUSE=""
 
 RDEPEND="dev-libs/libxml2
        media-libs/sdl-mixer
-       media-libs/libsdl
-       sys-libs/zlib"
+       media-libs/libsdl"
 DEPEND="${RDEPEND}
        app-arch/unzip"
 
-S="${WORKDIR}/u4"
+S=${WORKDIR}/u4
 
 pkg_setup() {
        if ! built_with_use media-libs/sdl-mixer timidity ; then
@@ -36,9 +35,9 @@ src_unpack() {
        # xu4 will read the data files right out of the zip files
        # but we want the docs from the original.
        unpack ${P}.tar.gz
-       cp ${DISTDIR}/{ultima4-1.01.zip,u4upgrad.zip} . \
+       cp "${DISTDIR}"/{ultima4-1.01.zip,u4upgrad.zip} . \
                || die "cp failed"
-       cd ${WORKDIR}
+       cd "${WORKDIR}"
        mv ultima4-1.01.zip ultima4.zip
        mkdir u4-dos
        cd u4-dos
@@ -46,7 +45,7 @@ src_unpack() {
        cd ${S}
        epatch "${FILESDIR}/${PV}-savegame.patch"
        sed -i \
-               -e "s:/usr/local/lib/u4:${GAMES_LIBDIR}/u4:" src/u4file.c \
+               -e "s:/usr/local/lib/u4:$(games_get_libdir)/u4:" src/u4file.c \
                || die "sed u4file failed"
        sed -i \
                -e 's:-Wall:$(E_CFLAGS):' src/Makefile \
@@ -59,20 +58,20 @@ src_compile() {
                E_CFLAGS="${CFLAGS}" \
                bindir="${GAMES_BINDIR}" \
                datadir="/usr/share" \
-               libdir="${GAMES_LIBDIR}" \
+               libdir="$(games_get_libdir)" \
                || die "emake failed"
 }
 
 src_install() {
-       make -C src \
+       emake -C src \
                DEBUGCFLAGS= \
                E_CFLAGS="${CFLAGS}" \
                bindir="${D}${GAMES_BINDIR}" \
                datadir="${D}/usr/share" \
-               libdir="${D}${GAMES_LIBDIR}" \
+               libdir="${D}$(games_get_libdir)" \
                install || die "make install failed"
        dodoc AUTHORS README doc/*txt "${WORKDIR}/u4-dos/ULTIMA4/"*TXT
-       insinto "${GAMES_LIBDIR}/u4"
+       insinto "$(games_get_libdir)/u4"
        doins "${WORKDIR}/"*zip || die "doins failed"
        prepgamesdirs
 }