dev-libs/bemenu: 0.4.1 bump
authorMatthew Thode <prometheanfire@gentoo.org>
Mon, 11 May 2020 03:37:20 +0000 (22:37 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Mon, 11 May 2020 03:37:20 +0000 (22:37 -0500)
Closes: https://bugs.gentoo.org/721798
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-libs/bemenu/Manifest
dev-libs/bemenu/bemenu-0.4.1.ebuild [new file with mode: 0644]

index a0f36bdb3f5824ed61a57c0f33f38527da64a506..24af94defea8c22e766456f76f811a575f1d8dd3 100644 (file)
@@ -1 +1,2 @@
 DIST bemenu-0.3.0.tar.gz 120059 BLAKE2B 5db3e7bcc4c67e9f7030fc803a5531994746787ebecfba91c7f09128ea9077b3b06e8f542c1a2980811b8364db3a54fefbdb0af1afaca2f58f098473a4fbd5d6 SHA512 7e68d11954517f41c9669055c28b375c4f13ddfee8aae6a8e67c3282fe9118229d9ab072dc5e264e4204803b1a5ab715c6a5c9565ad4b7436cc172b9e455c05b
+DIST bemenu-0.4.1.tar.gz 110388 BLAKE2B 229f75887b8efc336c7790745b1a3402481a1cb86f92311c0c46ec123777ad051351fede5f7d59bce532a3a906bcab8d956f1e93d5aeac44dd7a49e7210e8e9f SHA512 d86b80b2eccbfca73287975f6f5ff9d86c7541900caec858c9aeff9cb7da2ee563e34e378561822671ba16e0f2af3440e0329f5c77f06ff5adcf332451452bf2
diff --git a/dev-libs/bemenu/bemenu-0.4.1.ebuild b/dev-libs/bemenu/bemenu-0.4.1.ebuild
new file mode 100644 (file)
index 0000000..06c598e
--- /dev/null
@@ -0,0 +1,50 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="dmenu clone for wayland"
+HOMEPAGE="https://github.com/Cloudef/bemenu"
+if [[ ${PV} == 9999 ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/Cloudef/bemenu.git"
+else
+       SRC_URI="https://github.com/Cloudef/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="doc ncurses wayland X"
+
+# Require at least one backend be built
+REQUIRED_USE="|| ( ncurses wayland X )"
+
+DEPEND="
+       ncurses? ( sys-libs/ncurses:0 )
+       wayland? (
+               dev-libs/wayland
+               dev-libs/wayland-protocols
+               x11-libs/cairo
+               x11-libs/pango
+       )
+       X? (
+               x11-libs/libxcb
+               x11-libs/libXext
+               x11-libs/libX11
+               x11-libs/cairo[X]
+               x11-libs/pango[X]
+               x11-libs/libXinerama
+       )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="doc? ( app-doc/doxygen )"
+
+src_compile() {
+       emake clients $(usex ncurses curses) $(usex X x11) $(usex wayland wayland)
+       use doc && emake doxygen
+}
+
+src_install() {
+       emake install PREFIX="${D}"/usr libdir=/$(get_libdir)
+}