net-mail/list-remote-forwards: fix for ghc-8.4
authorSergei Trofimovich <slyfox@gentoo.org>
Sat, 14 Dec 2019 10:52:19 +0000 (10:52 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Sat, 14 Dec 2019 10:52:19 +0000 (10:52 +0000)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
net-mail/list-remote-forwards/files/list-remote-forwards-0.0.1-ghc84.patch [new file with mode: 0644]
net-mail/list-remote-forwards/list-remote-forwards-0.0.1-r2.ebuild [new file with mode: 0644]

diff --git a/net-mail/list-remote-forwards/files/list-remote-forwards-0.0.1-ghc84.patch b/net-mail/list-remote-forwards/files/list-remote-forwards-0.0.1-ghc84.patch
new file mode 100644 (file)
index 0000000..bf21a42
--- /dev/null
@@ -0,0 +1,26 @@
+--- a/src/OptionalConfiguration.hs
++++ b/src/OptionalConfiguration.hs
+@@ -31,2 +31,3 @@ import System.IO.Error ( catchIOError )
+ import MxList ( MxList(..) )
++import qualified Data.Semigroup as S
+@@ -59,2 +60,19 @@ merge_maybes (Just _) (Just y) = Just y
++instance S.Semigroup OptionalConfiguration where
++  cfg1 <> cfg2 =
++    OptionalConfiguration
++      (merge_maybes (database cfg1) (database cfg2))
++      (merge_maybes (domain_query cfg1) (domain_query cfg2))
++      all_excluded_mx
++      (merge_maybes (forward_query cfg1) (forward_query cfg2))
++      (merge_maybes (host cfg1) (host cfg2))
++      (merge_maybes (password cfg1) (password cfg2))
++      (merge_maybes (port cfg1) (port cfg2))
++      (merge_maybes (username cfg1) (username cfg2))
++    where
++      -- Use only the latter exclude_mx if there are any.
++      all_excluded_mx =
++        exclude_mx $ if (null (get_mxs $ exclude_mx cfg2))
++                     then cfg1
++                     else cfg2
diff --git a/net-mail/list-remote-forwards/list-remote-forwards-0.0.1-r2.ebuild b/net-mail/list-remote-forwards/list-remote-forwards-0.0.1-r2.ebuild
new file mode 100644 (file)
index 0000000..783e292
--- /dev/null
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.4.4
+
+CABAL_FEATURES="bin test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="List all remote forwards for mail accounts stored in a database"
+HOMEPAGE="http://hackage.haskell.org/package/list-remote-forwards"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT=test # Ambiguous packages: dns-3.0.2 resolv-0.1.1.1
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+       >=dev-haskell/cabal-1.16.0
+       >=dev-haskell/cmdargs-0.10
+       >=dev-haskell/configurator-0.2
+       >=dev-haskell/dns-1.4
+       >=dev-haskell/hdbc-2.4
+       >=dev-haskell/hdbc-postgresql-2.3
+       >=dev-haskell/hdbc-sqlite3-2.3
+       >=dev-haskell/missingh-1.2
+       >=dev-haskell/tasty-0.8
+       >=dev-haskell/tasty-hunit-0.8
+       >=dev-haskell/tasty-quickcheck-0.8
+       >=dev-lang/ghc-7.6.1
+       test? ( >=dev-haskell/doctest-0.9
+               >=dev-haskell/filemanip-0.3.6 )
+"
+
+PATCHES=(
+       "${FILESDIR}"/${P}-ghc84.patch
+)
+
+src_install() {
+       haskell-cabal_src_install
+       doman "${S}/doc/man1/${PN}.1"
+}