Version bump for 7.2RC3. Includes various bug fixes, including a fix for bug
authorJoshua Baergen <joshuabaergen@gentoo.org>
Sat, 2 Dec 2006 05:29:22 +0000 (05:29 +0000)
committerJoshua Baergen <joshuabaergen@gentoo.org>
Sat, 2 Dec 2006 05:29:22 +0000 (05:29 +0000)
#156788.
Package-Manager: portage-2.1.2_rc2-r3

x11-libs/libX11/ChangeLog
x11-libs/libX11/files/digest-libX11-1.1.1 [new file with mode: 0644]
x11-libs/libX11/libX11-1.1.1.ebuild [new file with mode: 0644]

index 13916271cdec3d828b1386727f433a4cce10991f..17efcd57d0fcdd3e8b94d824a267b57449ae7587 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for x11-libs/libX11
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libX11/ChangeLog,v 1.59 2006/11/24 09:43:57 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libX11/ChangeLog,v 1.60 2006/12/02 05:29:22 joshuabaergen Exp $
+
+*libX11-1.1.1 (02 Dec 2006)
+
+  02 Dec 2006; Joshua Baergen <joshuabaergen@gentoo.org> -libX11-1.1.ebuild,
+  +libX11-1.1.1.ebuild:
+  Version bump for 7.2RC3.  Includes various bug fixes, including a fix for bug
+  #156788.
 
 *libX11-1.1 (24 Nov 2006)
 
diff --git a/x11-libs/libX11/files/digest-libX11-1.1.1 b/x11-libs/libX11/files/digest-libX11-1.1.1
new file mode 100644 (file)
index 0000000..3770fe4
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 848b80f77b20ae1fa5c882bbfa531ebc libX11-1.1.1.tar.bz2 1426405
+RMD160 99c2d2bd6823c09667dffa5e4265924e93e76eef libX11-1.1.1.tar.bz2 1426405
+SHA256 5359db57793430429786b648ac570d4ab205797306e049bf1e8675250af21541 libX11-1.1.1.tar.bz2 1426405
diff --git a/x11-libs/libX11/libX11-1.1.1.ebuild b/x11-libs/libX11/libX11-1.1.1.ebuild
new file mode 100644 (file)
index 0000000..a16bee4
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libX11/libX11-1.1.1.ebuild,v 1.1 2006/12/02 05:29:22 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org X11 library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="ipv6 xcb"
+RDEPEND=">=x11-libs/xtrans-1.0.1
+       x11-libs/libXau
+       x11-libs/libXdmcp
+       x11-proto/kbproto
+       >=x11-proto/xproto-7.0.6
+       xcb? ( >=x11-libs/libxcb-1.0 )"
+DEPEND="${RDEPEND}
+       x11-proto/xf86bigfontproto
+       x11-proto/bigreqsproto
+       x11-proto/inputproto
+       x11-proto/xextproto
+       x11-proto/xcmiscproto
+       >=x11-misc/util-macros-0.99.0_p20051007"
+
+CONFIGURE_OPTIONS="$(use_enable ipv6)
+       $(use_with xcb)"
+# xorg really doesn't like xlocale disabled.
+# $(use_enable nls xlocale)