x11-terms/mlterm: new upstream release
authorAkinori Hattori <hattya@gentoo.org>
Sat, 14 Sep 2019 09:41:59 +0000 (18:41 +0900)
committerAkinori Hattori <hattya@gentoo.org>
Sat, 14 Sep 2019 09:41:59 +0000 (18:41 +0900)
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Akinori Hattori <hattya@gentoo.org>
x11-terms/mlterm/Manifest
x11-terms/mlterm/mlterm-3.8.8.ebuild [new file with mode: 0644]

index 02ecff9782a2c95a4c53887ec21cc944d0a3ad86..0bce6a1386b4ad73bc33ac4e031238755262d241 100644 (file)
@@ -1,3 +1,4 @@
 DIST mlterm-3.8.4.tar.gz 3881872 BLAKE2B 647810585b0143d0f680c99032cf478e02047acc80086b4c9cbadc59df49e09ba1626ee2ff2c8a1842c68047632c61001d31f7282d9eb8619f0260de7f0bb976 SHA512 6afe0a60001f180df18f2d2ad5e2954a1d9423313d7784eb0cf6a9736c6a62545f461d8e3d079aa1f43eb5f27f4b0c060a7da54e08bf758b283005b16aa1e5cd
 DIST mlterm-3.8.6.tar.gz 3952815 BLAKE2B e862bf449c801c260c50391af2e4c7cd541b945b3e77186b3d1a8b9395833613c98603084bfd199773e22dca1299cc3b669325a036dd4e827baa435b91d86e42 SHA512 da87a72fd31dbb1e0a4779ec070a5ef2a62a0861a114b61d57d564069c15eb927f26fb47d4973ac6f6c06d99abc2899502e8210f5f3e1c6d97d0b8b52414dfb1
 DIST mlterm-3.8.7.tar.gz 3994292 BLAKE2B c30991a7bb3a9f0a36d9f898087bda5b86e8282bc811e60430dc61ddd04c8c4cb6b9284ab178d8a6610aca2dcac785326e69e2088b2a7dee786451aa7c6a794c SHA512 6d2087d1433918f476e35dbde8d79940170fa6f133b9122e1db19006afc5081dbad7ed487bfa939b3d92ea29f3843a2b7c5540dc05e54b3c568bbe76ceb66ad2
+DIST mlterm-3.8.8.tar.gz 4035215 BLAKE2B 4ef85822915a1a15119ed771e0d2da0158e469b60cc8eafa9a118ba0ee0e4d4191fb0b5e371320978ff83b79907a42c9065d374dff8774bbac73f7ddb57be0af SHA512 4db7de441300d30eadc85d1c780bb10c81d2555225fe163280508180ccc2114eeacf0e5772f9d69c1b59ef6f3ffb3444b75fe3e5ea508dd9e18e5850e78f78a5
diff --git a/x11-terms/mlterm/mlterm-3.8.8.ebuild b/x11-terms/mlterm/mlterm-3.8.8.ebuild
new file mode 100644 (file)
index 0000000..c39aa42
--- /dev/null
@@ -0,0 +1,128 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit eutils
+
+DESCRIPTION="A multi-lingual terminal emulator"
+HOMEPAGE="http://mlterm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="bidi brltty cairo canna debug fbcon fcitx freewnn gtk gtk2 harfbuzz ibus libssh2 m17n-lib nls regis scim skk static-libs uim utempter wayland xft"
+REQUIRED_USE="gtk2? ( gtk )"
+
+RDEPEND="x11-libs/libICE
+       x11-libs/libSM
+       x11-libs/libX11
+       bidi? ( dev-libs/fribidi )
+       brltty? ( app-accessibility/brltty )
+       cairo? ( x11-libs/cairo[X(+)] )
+       canna? ( app-i18n/canna )
+       fbcon? ( media-fonts/unifont )
+       fcitx? ( app-i18n/fcitx )
+       freewnn? ( app-i18n/freewnn )
+       gtk? (
+               gtk2? ( x11-libs/gtk+:2 )
+               !gtk2? ( x11-libs/gtk+:3 )
+       )
+       harfbuzz? ( media-libs/harfbuzz[truetype(+)] )
+       ibus? ( app-i18n/ibus )
+       libssh2? ( net-libs/libssh2 )
+       m17n-lib? ( dev-libs/m17n-lib )
+       nls? ( virtual/libintl )
+       regis? (
+               || (
+                       media-libs/sdl-ttf
+                       media-libs/sdl2-ttf
+               )
+       )
+       scim? ( app-i18n/scim )
+       skk? (
+               || (
+                       virtual/skkserv
+                       app-i18n/skk-jisyo
+               )
+       )
+       uim? ( app-i18n/uim )
+       utempter? ( sys-libs/libutempter )
+       wayland? ( dev-libs/wayland )
+       xft? ( x11-libs/libXft )"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig
+       nls? ( sys-devel/gettext )"
+
+PATCHES=( "${FILESDIR}"/${PN}-font.patch )
+DOCS=( doc/{en,ja} )
+
+src_prepare() {
+       # default config
+       sed -i \
+               -e "/ icon_path =/aicon_path = ${EPREFIX}/usr/share/pixmaps/${PN}-icon.svg" \
+               -e "/ scrollbar_view_name =/ascrollbar_view_name = sample" \
+               etc/main
+
+       default
+}
+
+src_configure() {
+       local myconf=(
+               $(use_enable bidi fribidi)
+               $(use_enable brltty brlapi)
+               $(use_enable canna)
+               $(use_enable debug)
+               $(use_enable fcitx)
+               $(use_enable freewnn wnn)
+               $(use_enable harfbuzz otl)
+               $(use_enable ibus)
+               $(use_enable libssh2 ssh2)
+               $(use_enable m17n-lib m17nlib)
+               $(use_enable nls)
+               $(use_enable scim)
+               $(use_enable skk)
+               $(use_enable uim)
+               $(use_enable utempter utmp)
+               --with-gui=xlib$(usex fbcon ",fb" "")$(usex wayland ",wayland" "")
+               --with-type-engines=xcore$(usex xft ",xft" "")$(usex cairo ",cairo" "")
+               --enable-optimize-redrawing
+               --enable-vt52
+               --disable-static
+       )
+
+       local scrollbars="sample,extra"
+       local tools="mlclient,mlcc,mlfc,mlmenu,${PN}-zoom"
+       if use gtk; then
+               myconf+=(
+                       $(use_with gtk gtk $(usex gtk2 2.0 3.0))
+                       --with-imagelib=gdk-pixbuf
+               )
+               scrollbars+=",pixmap_engine"
+               tools+=",mlconfig,mlimgloader"
+       fi
+       if use regis; then
+               tools+=",registobmp"
+       fi
+       myconf+=( --with-scrollbars="${scrollbars}" )
+       myconf+=( --with-tools="${tools}" )
+
+       addpredict /dev/ptmx
+       econf "${myconf[@]}"
+}
+
+src_test() {
+       :
+}
+
+src_install () {
+       default
+       find "${ED}" -name '*.la' -delete || die
+
+       docinto contrib/icon
+       dodoc contrib/icon/README
+
+       doicon contrib/icon/${PN}*
+       make_desktop_entry ${PN} ${PN} ${PN}-icon "System;TerminalEmulator"
+}