dev-java/jsr173: convert to java-pkg-simple.
authorPatrice Clement <monsieurp@gentoo.org>
Fri, 23 Dec 2016 09:44:35 +0000 (10:44 +0100)
committerPatrice Clement <monsieurp@gentoo.org>
Fri, 23 Dec 2016 10:06:48 +0000 (11:06 +0100)
Package-Manager: portage-2.3.0

dev-java/jsr173/jsr173-1.0-r3.ebuild [new file with mode: 0644]

diff --git a/dev-java/jsr173/jsr173-1.0-r3.ebuild b/dev-java/jsr173/jsr173-1.0-r3.ebuild
new file mode 100644 (file)
index 0000000..71d6b02
--- /dev/null
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Yet another Java library for parsing and writing XML"
+HOMEPAGE="http://dev2dev.bea.com/xml/stax.html"
+SRC_URI="http://ftpna2.bea.com/pub/downloads/${PN}.jar"
+
+LICENSE="bea.ri.jsr173"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+CDEPEND="dev-java/jaxme:0"
+
+RDEPEND="
+       ${CDEPEND}
+       >=virtual/jre-1.6"
+
+DEPEND="
+       ${CDEPEND}
+       >=virtual/jdk-1.6"
+
+S="${WORKDIR}"
+
+JAVA_GENTOO_CLASSPATH="jaxme"
+
+src_unpack() {
+       cd "${S}" || die
+       jar xvf "${DISTDIR}/${A}" || die "failed to unpack"
+       jar xvf "${P//-/_}_src.jar" || die "failed to unpack"
+}
+
+src_prepare() {
+       default
+       cd "${S}" || die
+       java-pkg_clean
+}
+
+src_compile() {
+       java-pkg-simple_src_compile
+}